summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-02-04 19:58:33 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-02-04 19:58:33 +0000
commitf34c8c0f37642c42db8551eeddbe7ee05e6e5f56 (patch)
tree136c30fce83d4952ea5de9cbe6bd782b1b31dbe4 /x11-misc/xkeyboard-config
parentFixed as-needed bug #500272 (diff)
downloadgentoo-2-f34c8c0f37642c42db8551eeddbe7ee05e6e5f56.tar.gz
gentoo-2-f34c8c0f37642c42db8551eeddbe7ee05e6e5f56.tar.bz2
gentoo-2-f34c8c0f37642c42db8551eeddbe7ee05e6e5f56.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/ChangeLog10
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.11.ebuild48
2 files changed, 56 insertions, 2 deletions
diff --git a/x11-misc/xkeyboard-config/ChangeLog b/x11-misc/xkeyboard-config/ChangeLog
index ef75084ca13a..38fad4edd0d9 100644
--- a/x11-misc/xkeyboard-config/ChangeLog
+++ b/x11-misc/xkeyboard-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xkeyboard-config
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.192 2013/10/08 05:09:09 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.193 2014/02/04 19:58:33 chithanh Exp $
+
+*xkeyboard-config-2.11 (04 Feb 2014)
+
+ 04 Feb 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xkeyboard-config-2.11.ebuild:
+ Version bump.
08 Oct 2013; Agostino Sarubbo <ago@gentoo.org> xkeyboard-config-2.9.ebuild:
Stable for x86, wrt bug #475480
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.11.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.11.ebuild
new file mode 100644
index 000000000000..e934cdcb4366
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-2.11.ebuild,v 1.1 2014/02/04 19:58:33 chithanh Exp $
+
+EAPI=5
+
+XORG_STATIC=no
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+[[ ${PV} == *9999* ]] || SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/data/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=x11-apps/xkbcomp-1.2.3
+ >=x11-libs/libX11-1.4.3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ >=x11-proto/xproto-7.0.20"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+)
+
+src_prepare() {
+ xorg-2_src_prepare
+ if [[ ${XORG_EAUTORECONF} != no ]]; then
+ intltoolize --copy --automake || die
+ fi
+}
+
+src_compile() {
+ # cleanup to make sure .dir files are regenerated
+ # bug #328455 c#26
+ xorg-2_src_compile clean
+ xorg-2_src_compile
+}