summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-25 06:57:46 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-25 06:57:46 +0000
commitbf3927ae950b7e46f5ed3c9b7cd62c8c67d88c51 (patch)
treec8589512116b51577df864e2b97580f664dd9ab2 /x11-misc/xmbdfed/xmbdfed-4.5.ebuild
parentyay fix 9188, no X needed (diff)
downloadgentoo-2-bf3927ae950b7e46f5ed3c9b7cd62c8c67d88c51.tar.gz
gentoo-2-bf3927ae950b7e46f5ed3c9b7cd62c8c67d88c51.tar.bz2
gentoo-2-bf3927ae950b7e46f5ed3c9b7cd62c8c67d88c51.zip
new package
Diffstat (limited to 'x11-misc/xmbdfed/xmbdfed-4.5.ebuild')
-rw-r--r--x11-misc/xmbdfed/xmbdfed-4.5.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/xmbdfed/xmbdfed-4.5.ebuild b/x11-misc/xmbdfed/xmbdfed-4.5.ebuild
new file mode 100644
index 000000000000..5f6a92015c95
--- /dev/null
+++ b/x11-misc/xmbdfed/xmbdfed-4.5.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xmbdfed/xmbdfed-4.5.ebuild,v 1.1 2002/10/25 06:57:46 seemant Exp $
+
+IUSE="truetype"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="BDF font editor for X"
+SRC_URI="http://clr.nmsu.edu/~mleisher/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.diff.bz2"
+HOMEPAGE="http://clr.nmsu.edu/~mleisher/xmbdfed.html"
+
+
+SLOT="0"
+LICNSE="as-is"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11
+ >=x11-libs/openmotif-2.1.30
+ truetype? ( =media-libs/freetype-1.3* )"
+
+# The xmbdfed-4.5-gentoo.diff includes patch 1 for version 4.5. The
+# author hasn't distributed a new numbered release yet, so I've
+# blended the patch in with a small include file fix needed for the
+# Gentoo install of freetype.
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ${WORKDIR}/${P}-gentoo.diff || die
+}
+
+src_compile() {
+
+# There's no ./configure in xmbdfed, so perform the make by manually
+# specifying the correct options for Gentoo.
+
+ local flags=""
+ local incs=""
+ local libs=""
+
+ incs="-I/usr/X11R6/include"
+ libs="-L/usr/X11R6/lib -lXm -lXpm -lXmu -lXt -lXext -lX11 -lSM -lICE"
+
+ if use truetype
+ then
+ flags="FTYPE_DEFS=\"-DHAVE_FREETYPE\""
+ incs="${incs} -I/usr/include/freetype"
+ libs="${libs} -lttf"
+ fi
+
+
+ make CFLAGS="${CFLAGS}" ${flags} \
+ INCS="${incs}" \
+ LIBS="${libs}"
+}
+
+src_install () {
+ dobin xmbdfed
+ newman xmbdfed.man xmbdfed.1
+ dodoc CHANGES COPYRIGHTS INSTALL README xmbdfedrc
+}