summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-01-23 18:46:17 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-01-23 18:46:17 +0000
commit4896c1f1c8e3dc70cc8359734416201e77118173 (patch)
tree5c16f60a6d2dcb83b254ffc142cdfdf1a66ebe5e /x11-misc
parentVersion bump; Gentoo patching is still necessary. (diff)
downloadgentoo-2-4896c1f1c8e3dc70cc8359734416201e77118173.tar.gz
gentoo-2-4896c1f1c8e3dc70cc8359734416201e77118173.tar.bz2
gentoo-2-4896c1f1c8e3dc70cc8359734416201e77118173.zip
Use pkg-config instead of xft-config for libXft detection wrt #397739 by "Weonbin"
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/enter/ChangeLog9
-rw-r--r--x11-misc/enter/enter-0.0.9.ebuild31
-rw-r--r--x11-misc/enter/files/enter-0.0.9-build.patch27
3 files changed, 47 insertions, 20 deletions
diff --git a/x11-misc/enter/ChangeLog b/x11-misc/enter/ChangeLog
index deccb8d15d12..498c585a0168 100644
--- a/x11-misc/enter/ChangeLog
+++ b/x11-misc/enter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/enter
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/enter/ChangeLog,v 1.1 2010/06/20 21:22:49 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/enter/ChangeLog,v 1.2 2012/01/23 18:46:17 ssuominen Exp $
+
+ 23 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> enter-0.0.9.ebuild,
+ +files/enter-0.0.9-build.patch:
+ Use pkg-config instead of xft-config for libXft detection wrt #397739 by
+ "Weonbin"
*enter-0.0.9 (20 Jun 2010)
diff --git a/x11-misc/enter/enter-0.0.9.ebuild b/x11-misc/enter/enter-0.0.9.ebuild
index 6161b2eca5c8..be0f284e31bd 100644
--- a/x11-misc/enter/enter-0.0.9.ebuild
+++ b/x11-misc/enter/enter-0.0.9.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/enter/enter-0.0.9.ebuild,v 1.1 2010/06/20 21:22:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/enter/enter-0.0.9.ebuild,v 1.2 2012/01/23 18:46:17 ssuominen Exp $
-EAPI=2
-inherit autotools
+EAPI=4
+inherit autotools eutils
DESCRIPTION="A lightweight graphical login manager for X"
HOMEPAGE="http://enter.sourceforge.net/"
@@ -14,24 +14,19 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-RDEPEND="x11-libs/libXau
- x11-libs/libXext
- x11-libs/libXft
+RDEPEND=">=media-libs/freetype-2
+ media-libs/imlib2
x11-libs/libX11
- media-libs/imlib2"
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXft"
DEPEND="${RDEPEND}
- >=media-libs/freetype-2
+ dev-util/pkgconfig
x11-proto/xproto"
-src_prepare() {
- sed -i \
- -e 's:enter_LDFLAGS:enter_LDADD:' \
- src/Makefile.am || die
+DOCS="AUTHORS ChangeLog README TODO"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
eautoreconf
}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog README TODO
-}
diff --git a/x11-misc/enter/files/enter-0.0.9-build.patch b/x11-misc/enter/files/enter-0.0.9-build.patch
new file mode 100644
index 000000000000..21a19a07bcc6
--- /dev/null
+++ b/x11-misc/enter/files/enter-0.0.9-build.patch
@@ -0,0 +1,27 @@
+http://bugs.gentoo.org/397739
+
+--- configure.ac
++++ configure.ac
+@@ -32,11 +32,8 @@
+
+ AC_CHECK_FT2
+
+-AC_PATH_PROGS([XFT_CONFIG], [xft-config], [none])
+-if test "x$XFT_CONFIG" = "xnone"; then
+- AC_MSG_ERROR([You need to have libXft.])
+-fi
+-XFT_LIBS=`$XFT_CONFIG --libs`
++PKG_CHECK_MODULES([XFT], [xft])
++
+ AC_CHECK_LIB([Xft], [XftFontOpenName],,
+ AC_MSG_ERROR([You need to have libXft.]))
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -20,5 +20,5 @@
+ gui.c gui.h
+
+ enter_CFLAGS = @DEBUG_CFLAGS@ @FT2_CFLAGS@ @IMLIB_CFLAGS@ @X_CFLAGS@ -DCONFDIR=\"$(sysconfdir)\" -DTHEMEDIR=\"$(datadir)/@PACKAGE@/themes\"
+-enter_LDFLAGS = @X_LIBS@ @IMLIB_LIBS@ @FT2_LIBS@ -lcrypt
++enter_LDADD = @X_LIBS@ @IMLIB_LIBS@ @FT2_LIBS@ -lcrypt
+