summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Østergaard <kloeri@gentoo.org>2006-10-10 18:55:33 +0000
committerBryan Østergaard <kloeri@gentoo.org>2006-10-10 18:55:33 +0000
commitde7131c803fd001a7834dd66ea54fc301beec29a (patch)
tree819e68245e2a9dd6e2e4859c365150241f83528e /x11-plugins/ascpu/ascpu-1.11.ebuild
parentStable on sparc wrt #146939 (diff)
downloadgentoo-2-de7131c803fd001a7834dd66ea54fc301beec29a.tar.gz
gentoo-2-de7131c803fd001a7834dd66ea54fc301beec29a.tar.bz2
gentoo-2-de7131c803fd001a7834dd66ea54fc301beec29a.zip
Modular X fixes, bug 147232.
(Portage version: 2.1.2_pre2-r6)
Diffstat (limited to 'x11-plugins/ascpu/ascpu-1.11.ebuild')
-rw-r--r--x11-plugins/ascpu/ascpu-1.11.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/ascpu/ascpu-1.11.ebuild b/x11-plugins/ascpu/ascpu-1.11.ebuild
new file mode 100644
index 000000000000..7ac1d767c872
--- /dev/null
+++ b/x11-plugins/ascpu/ascpu-1.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/ascpu/ascpu-1.11.ebuild,v 1.1 2006/10/10 18:55:33 kloeri Exp $
+
+inherit eutils toolchain-funcs
+
+IUSE="jpeg"
+DESCRIPTION="CPU statistics monitor utility for X Windows"
+SRC_URI="http://www.tigr.net/afterstep/download/ascpu/${P}.tar.gz"
+HOMEPAGE="http://www.tigr.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc ~mips ~ppc64 ~amd64"
+
+RDEPEND="x11-libs/libXpm
+ x11-libs/libSM
+ jpeg? ( media-libs/jpeg )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ econf $(use_enable jpeg) || die "econf failed"
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}