summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2005-12-12 20:47:20 +0000
committerMark Loeser <halcy0n@gentoo.org>2005-12-12 20:47:20 +0000
commitec756fe492173d9983a7b3a975dd07be31ecc315 (patch)
treea0fb24813f034992e7645981d8d48e7ecacaa29d /x11-plugins/autoprofile/autoprofile-2.10.ebuild
parentMarked stable on amd64 (diff)
downloadgentoo-2-ec756fe492173d9983a7b3a975dd07be31ecc315.tar.gz
gentoo-2-ec756fe492173d9983a7b3a975dd07be31ecc315.tar.bz2
gentoo-2-ec756fe492173d9983a7b3a975dd07be31ecc315.zip
Add patch to fix compilation with gcc-4; bug #99063
(Portage version: 2.0.53)
Diffstat (limited to 'x11-plugins/autoprofile/autoprofile-2.10.ebuild')
-rw-r--r--x11-plugins/autoprofile/autoprofile-2.10.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/x11-plugins/autoprofile/autoprofile-2.10.ebuild b/x11-plugins/autoprofile/autoprofile-2.10.ebuild
index 157d537b578d..9e1a5e07e1dd 100644
--- a/x11-plugins/autoprofile/autoprofile-2.10.ebuild
+++ b/x11-plugins/autoprofile/autoprofile-2.10.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/autoprofile/autoprofile-2.10.ebuild,v 1.2 2004/10/21 15:41:33 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/autoprofile/autoprofile-2.10.ebuild,v 1.3 2005/12/12 20:47:20 halcy0n Exp $
+
+inherit eutils
DESCRIPTION="AutoProfile is a fully-featured profile manager for the popular instant messenger client Gaim."
HOMEPAGE="http://hkn.eecs.berkeley.edu/~casey/autoprofile/"
@@ -11,6 +13,12 @@ KEYWORDS="x86 ppc"
IUSE=""
DEPEND=">=net-im/gaim-1.0.0"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}"/${P}-gcc4.patch
+}
+
src_compile() {
emake || die
}