summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2006-07-26 05:03:57 +0000
committerJoshua Kinard <kumba@gentoo.org>2006-07-26 05:03:57 +0000
commitc9e97e7e5519c8fa07c0af1fde50fb09fd478f6c (patch)
tree80a711ad4ae544177ce6cb04ab47dcf51f81fbd6 /x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild
parentStabling gnome-vfs on mips for now to satisfy some old repoman deps. Eventua... (diff)
downloadgentoo-2-c9e97e7e5519c8fa07c0af1fde50fb09fd478f6c.tar.gz
gentoo-2-c9e97e7e5519c8fa07c0af1fde50fb09fd478f6c.tar.bz2
gentoo-2-c9e97e7e5519c8fa07c0af1fde50fb09fd478f6c.zip
Modified ebuild to use the 0.2 patchball from thunderbird, uses *.patch suffix for epatch, removed anarchy's devdir from SRC_URL (404), and added unstable mips keyword. See thunderbird changelog for the parent change cauing the patchball update.
(Portage version: 2.1.1_pre2-r8)
Diffstat (limited to 'x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild')
-rw-r--r--x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild b/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild
index 638e6033a804..82ce452862ef 100644
--- a/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild
+++ b/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild
@@ -1,22 +1,21 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild,v 1.5 2006/06/06 17:06:51 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild,v 1.6 2006/07/26 05:03:57 kumba Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
inherit flag-o-matic toolchain-funcs eutils nsplugins mozcoreconf makeedit multilib autotools
EMVER=${PV}
TBVER="1.5.0.4"
-TBPVER="0.1"
+TBPVER="0.2"
DESCRIPTION="Gnupg encryption plugin for thunderbird."
HOMEPAGE="http://www.enigmail.mozdev.org"
SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}-source.tar.bz2
mirror://gentoo/mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2
- http://dev.gentoo.org/~anarchy/dist/mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2
http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz"
-KEYWORDS="amd64 ~ia64 ppc sparc x86"
+KEYWORDS="amd64 ~ia64 ppc sparc x86 ~mips"
SLOT="0"
LICENSE="MPL-1.1 NPL-1.1"
IUSE=""
@@ -40,7 +39,9 @@ src_unpack() {
cd ${S} || die "cd failed"
# Apply our patches
- EPATCH_FORCE="yes" epatch ${WORKDIR}/patch
+ EPATCH_SUFFIX="patch" \
+ EPATCH_FORCE="yes" \
+ epatch ${WORKDIR}/patch
# Unpack the enigmail plugin
cd ${S}/mailnews/extensions || die