summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:45:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:45:04 +0000
commit126c884b3d8c145580ebd4c7326cb8842ae3d1c4 (patch)
tree38d8da9baabd0a820ee7973ecfb9167862d0603e /x11-plugins/fsviewer
parentarm stable, bug #506702 (diff)
downloadgentoo-2-126c884b3d8c145580ebd4c7326cb8842ae3d1c4.tar.gz
gentoo-2-126c884b3d8c145580ebd4c7326cb8842ae3d1c4.tar.bz2
gentoo-2-126c884b3d8c145580ebd4c7326cb8842ae3d1c4.zip
Use EAPI5 instead of EAPI1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins/fsviewer')
-rw-r--r--x11-plugins/fsviewer/ChangeLog8
-rw-r--r--x11-plugins/fsviewer/fsviewer-0.2.5.ebuild30
-rw-r--r--x11-plugins/fsviewer/fsviewer-0.2.6.ebuild11
3 files changed, 24 insertions, 25 deletions
diff --git a/x11-plugins/fsviewer/ChangeLog b/x11-plugins/fsviewer/ChangeLog
index 4a2bcea1ec92..a0c6ae34080f 100644
--- a/x11-plugins/fsviewer/ChangeLog
+++ b/x11-plugins/fsviewer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/fsviewer
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/ChangeLog,v 1.21 2012/07/11 22:06:05 voyageur Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/ChangeLog,v 1.22 2014/04/07 19:45:04 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> fsviewer-0.2.5.ebuild,
+ fsviewer-0.2.6.ebuild:
+ Use EAPI5 instead of EAPI1.
11 Jul 2012; Bernard Cafarelli <voyageur@gentoo.org> fsviewer-0.2.5.ebuild,
fsviewer-0.2.6.ebuild, +files/fsviewer-0.2.6-wmaker-0.95_support.patch:
diff --git a/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild b/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild
index 37b41c961187..3c3b06b66b7b 100644
--- a/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild
+++ b/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild,v 1.13 2012/07/11 22:06:05 voyageur Exp $
-
-EAPI=1
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/fsviewer-0.2.5.ebuild,v 1.14 2014/04/07 19:45:04 ssuominen Exp $
+EAPI=5
inherit eutils
MY_PN=FSViewer
@@ -17,15 +16,14 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="
- dev-libs/expat
+RDEPEND="dev-libs/expat
media-libs/tiff:0
media-libs/giflib
media-libs/libpng:0
media-libs/fontconfig
media-libs/freetype
sys-libs/zlib
- virtual/jpeg
+ virtual/jpeg:0
x11-libs/libproplist
x11-libs/libSM
x11-libs/libICE
@@ -41,22 +39,18 @@ DEPEND="
x11-proto/xextproto
x11-proto/xproto
<x11-wm/windowmaker-0.95.0"
-RDEPEND=${DEPEND}
+DEPEND=${RDEPEND}
S=${WORKDIR}/${MY_PN}.app-${PV}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+DOCS=""
+
+src_prepare() {
epatch "${FILESDIR}"/${P}-windowmaker.patch
}
-src_compile() {
- econf --with-appspath=/usr/lib/GNUstep \
+src_configure() {
+ econf \
+ --with-appspath=/usr/lib/GNUstep \
--with-extralibs=-lXft
- emake || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
}
diff --git a/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild b/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild
index daa9d786fd0a..cdc7498373c3 100644
--- a/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild
+++ b/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild,v 1.2 2012/07/11 22:06:05 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/fsviewer/fsviewer-0.2.6.ebuild,v 1.3 2014/04/07 19:45:04 ssuominen Exp $
-EAPI=4
+EAPI=5
inherit autotools eutils multilib
MY_P=${PN}-app-${PV}
@@ -26,6 +26,8 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+DOCS="AUTHORS ChangeLog NEWS README"
+
src_prepare() {
epatch "${FILESDIR}"/${P}-wmaker-0.95_support.patch
eautoreconf
@@ -38,7 +40,6 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install
+ default
dosym /usr/$(get_libdir)/GNUstep/FSViewer.app/FSViewer /usr/bin/FSViewer
- dodoc AUTHORS ChangeLog NEWS README
}