summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-01-24 03:07:19 +0000
committerDon Seiler <rizzo@gentoo.org>2005-01-24 03:07:19 +0000
commit26a39fdadc0f32bf44baa9b9c1869185f0df409d (patch)
treec8d90ba2bce11e3d497323a1422bacc708bba124 /x11-plugins/gaim-encryption/gaim-encryption-2.34.ebuild
parentcode cleanup (diff)
downloadgentoo-2-26a39fdadc0f32bf44baa9b9c1869185f0df409d.tar.gz
gentoo-2-26a39fdadc0f32bf44baa9b9c1869185f0df409d.tar.bz2
gentoo-2-26a39fdadc0f32bf44baa9b9c1869185f0df409d.zip
Version bump, pulling 2.33
(Portage version: 2.0.51-r14)
Diffstat (limited to 'x11-plugins/gaim-encryption/gaim-encryption-2.34.ebuild')
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-2.34.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-2.34.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-2.34.ebuild
new file mode 100644
index 000000000000..5e073e658446
--- /dev/null
+++ b/x11-plugins/gaim-encryption/gaim-encryption-2.34.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.34.ebuild,v 1.1 2005/01/24 03:07:19 rizzo Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~ppc64"
+IUSE=""
+
+DEPEND=">=net-im/gaim-1.0.1
+ >=dev-libs/nss-3.9.2-r2"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+
+ local myconf
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+ myconf="${myconf} --with-nspr-libs=/usr/lib/nspr"
+ myconf="${myconf} --with-nss-libs=/usr/lib/nss"
+
+ econf ${myconf} || die "Configuration failed"
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}