summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-08-31 14:41:51 +0000
committerPacho Ramos <pacho@gentoo.org>2013-08-31 14:41:51 +0000
commit58b22a6ea72d2130cb10aa2fea5ea7f648aa1a8d (patch)
treefac3a8fdf27c510ab861e9073d6224b91f26db62 /x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
parentmask custom-cflags for media-libs/libsdl2 since it's unsupported (diff)
downloadgentoo-2-58b22a6ea72d2130cb10aa2fea5ea7f648aa1a8d.tar.gz
gentoo-2-58b22a6ea72d2130cb10aa2fea5ea7f648aa1a8d.tar.bz2
gentoo-2-58b22a6ea72d2130cb10aa2fea5ea7f648aa1a8d.zip
Fix LDFLAGS/gcc usage (#338903), deps (#421703) and gcc-4.7 building (#426454). By Michael Mair-Keimberger (iamnr3).
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild')
-rw-r--r--x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild b/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
index 4207cf571196..62ae5cbb6cc2 100644
--- a/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
+++ b/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
@@ -1,23 +1,35 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild,v 1.13 2007/03/09 16:01:53 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild,v 1.14 2013/08/31 14:41:51 pacho Exp $
-inherit gkrellm-plugin
+EAPI="5"
+inherit eutils gkrellm-plugin toolchain-funcs
MY_P=${P/-/_}
-IUSE=""
+
DESCRIPTION="an Image-Watcher-Plugin for GKrellM2."
SRC_URI="mirror://sourceforge/gkrellkam/${MY_P}.tar.gz"
HOMEPAGE="http://gkrellkam.sourceforge.net"
LICENSE="GPL-2"
SLOT="0"
+IUSE=""
KEYWORDS="x86 ppc sparc alpha amd64"
-RDEPEND="net-misc/wget"
+RDEPEND="net-misc/wget
+ app-admin/gkrellm[X]"
+DEPEND="${RDEPEND}"
PLUGIN_SO=gkrellkam2.so
PLUGIN_DOCS="example.list"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
src_install () {
gkrellm-plugin_src_install
doman gkrellkam-list.5