summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-07-20 17:25:54 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-07-20 17:25:54 +0000
commit287c59045abb0772da3650c2c7fbb74a274cd251 (patch)
treef9f00708cc5d63b0f2451784173fc0cd9baf41fd /x11-plugins/gkrellsun/gkrellsun-0.12.1.ebuild
parentfix possible buffer overflow, remove vulnerable versions (Manifest recommit) (diff)
downloadgentoo-2-287c59045abb0772da3650c2c7fbb74a274cd251.tar.gz
gentoo-2-287c59045abb0772da3650c2c7fbb74a274cd251.tar.bz2
gentoo-2-287c59045abb0772da3650c2c7fbb74a274cd251.zip
Version bumped. Closes 51481
Diffstat (limited to 'x11-plugins/gkrellsun/gkrellsun-0.12.1.ebuild')
-rw-r--r--x11-plugins/gkrellsun/gkrellsun-0.12.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-plugins/gkrellsun/gkrellsun-0.12.1.ebuild b/x11-plugins/gkrellsun/gkrellsun-0.12.1.ebuild
new file mode 100644
index 000000000000..8058b32f899e
--- /dev/null
+++ b/x11-plugins/gkrellsun/gkrellsun-0.12.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellsun/gkrellsun-0.12.1.ebuild,v 1.1 2004/07/20 17:25:54 mholzer Exp $
+
+IUSE=""
+DESCRIPTION="A GKrellM plugin that shows sunrise and sunset times."
+HOMEPAGE="http://gkrellsun.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellsun/${P}.tar.gz"
+
+SLOT="1"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~amd64 ~ia64"
+
+DEPEND="=app-admin/gkrellm-2*
+ >=media-libs/imlib-1.9.10-r1"
+
+src_compile() {
+ cd ${S}/src20
+ emake || die
+}
+
+src_install () {
+ dodoc README AUTHORS COPYING
+
+ cd ${S}/src20
+ insinto /usr/lib/gkrellm2/plugins
+ doins gkrellsun.so
+}