summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-03-13 00:29:15 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-03-13 00:29:15 +0000
commitab2a1ee0fe80c1d6c980f54dc099b7d31a367b3c (patch)
treeb267b1a58f4d3fe5ca3170d063340424ce654a17 /x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild
parentX is implicit (diff)
downloadgentoo-2-ab2a1ee0fe80c1d6c980f54dc099b7d31a367b3c.tar.gz
gentoo-2-ab2a1ee0fe80c1d6c980f54dc099b7d31a367b3c.tar.bz2
gentoo-2-ab2a1ee0fe80c1d6c980f54dc099b7d31a367b3c.zip
- Initial import. Original ebuild by Priit Laes, modifications by Björn Ruberg and Yuri Vasilevski.
(Portage version: 2.1_pre6)
Diffstat (limited to 'x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild')
-rw-r--r--x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild b/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild
new file mode 100644
index 000000000000..610b30930b53
--- /dev/null
+++ b/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/matchbox-applet-volume/matchbox-applet-volume-0.1.ebuild,v 1.1 2006/03/13 00:29:15 yvasilev Exp $
+
+inherit versionator
+
+MY_PN=${PN/matchbox/mb}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Matchbox panel tray app for controlling volume levels."
+HOMEPAGE="http://projects.o-hand.com/matchbox/"
+SRC_URI="http://projects.o-hand.com/matchbox/sources/${MY_PN}/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+ >=x11-libs/gtk+-2.0.3"
+
+RDEPEND="${DEPEND}
+ x11-wm/matchbox-panel"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc AUTHORS Changelog INSTALL NEWS README
+}