summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-21 15:22:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-21 15:22:28 +0000
commit368c3689488c84b113bcfe9bd4fd2274f7754ae3 (patch)
tree8b31be6d40eda50f43edf3815b93204f02f93c97 /x11-plugins/wmbiff
parentadd dev-lang/perl to DEPEND wrt bug #422629 (diff)
downloadgentoo-2-368c3689488c84b113bcfe9bd4fd2274f7754ae3.tar.gz
gentoo-2-368c3689488c84b113bcfe9bd4fd2274f7754ae3.tar.bz2
gentoo-2-368c3689488c84b113bcfe9bd4fd2274f7754ae3.zip
Fix sys-devel/automake >= 1.12 compability wrt #421411
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmbiff')
-rw-r--r--x11-plugins/wmbiff/ChangeLog5
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.27.ebuild27
2 files changed, 17 insertions, 15 deletions
diff --git a/x11-plugins/wmbiff/ChangeLog b/x11-plugins/wmbiff/ChangeLog
index b3a9cd59ecdb..f5c698caf91a 100644
--- a/x11-plugins/wmbiff/ChangeLog
+++ b/x11-plugins/wmbiff/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmbiff
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/ChangeLog,v 1.30 2012/05/05 05:12:01 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/ChangeLog,v 1.31 2012/06/21 15:22:28 ssuominen Exp $
+
+ 21 Jun 2012; Samuli Suominen <ssuominen@gentoo.org> wmbiff-0.4.27.ebuild:
+ Fix sys-devel/automake >= 1.12 compability wrt #421411
05 May 2012; Jeff Horelick <jdhore@gentoo.org> wmbiff-0.4.27.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
index de3267e469b6..6a6c4a0af8b8 100644
--- a/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
+++ b/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild,v 1.9 2012/05/05 05:12:01 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbiff/wmbiff-0.4.27.ebuild,v 1.10 2012/06/21 15:22:28 ssuominen Exp $
-EAPI=2
+EAPI=4
inherit autotools eutils
DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes."
HOMEPAGE="http://sourceforge.net/projects/wmbiff/"
-SRC_URI="mirror://sourceforge/wmbiff/${P}.tar.gz"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
@@ -17,25 +17,24 @@ IUSE="crypt"
RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm
- crypt? ( >=net-libs/gnutls-1.2.3
- >=dev-libs/libgcrypt-1.2.1 )"
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.1
+ >=net-libs/gnutls-1.2.3
+ )"
DEPEND="${RDEPEND}
virtual/pkgconfig
- x11-proto/xproto
- x11-proto/xextproto"
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="ChangeLog FAQ NEWS README README.licq TODO wmbiff/sample.wmbiffrc"
src_prepare() {
epatch "${FILESDIR}"/${P}-gnutls.patch
sed -i -e '/AC_PATH_XTRA_CORRECTED/d' configure.ac || die
+ sed -i -e '/pkg.*SCRIPTS/s:pkglib:pkgdata:' scripts/Makefile.am #421411
eautoreconf
}
src_configure() {
- econf \
- $(use_enable crypt crypto)
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc ChangeLog FAQ NEWS README README.licq TODO wmbiff/sample.wmbiffrc
+ econf $(use_enable crypt crypto)
}