summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2007-03-14 16:30:46 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2007-03-14 16:30:46 +0000
commit1a11742cce385ab518e7ce8f5870731ddc87be82 (patch)
treebf5171772b1f0a9a96a6baa2ce28da05b3635927 /x11-plugins/wmcpu/wmcpu-1.4.ebuild
parentVersion bump thanks to mark in bug 161442 (diff)
downloadgentoo-2-1a11742cce385ab518e7ce8f5870731ddc87be82.tar.gz
gentoo-2-1a11742cce385ab518e7ce8f5870731ddc87be82.tar.bz2
gentoo-2-1a11742cce385ab518e7ce8f5870731ddc87be82.zip
Initial import. Closes bug #105601
(Portage version: 2.1.2.2)
Diffstat (limited to 'x11-plugins/wmcpu/wmcpu-1.4.ebuild')
-rw-r--r--x11-plugins/wmcpu/wmcpu-1.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmcpu/wmcpu-1.4.ebuild b/x11-plugins/wmcpu/wmcpu-1.4.ebuild
new file mode 100644
index 000000000000..f154f803771a
--- /dev/null
+++ b/x11-plugins/wmcpu/wmcpu-1.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmcpu/wmcpu-1.4.ebuild,v 1.1 2007/03/14 16:30:46 s4t4n Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="wmcpu is a dockapp to monitor memory and CPU usage, similar to xosview"
+HOMEPAGE="http://dockapps.org/file.php/id/306"
+SRC_URI="http://denilsonsa.sh.nu/~denilson/${P}.tar.gz
+ http://denilsonsa.selfip.org/~denilson/${P}.tar.gz
+ http://dockapps.org/download.php/id/673/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm )
+ virtual/x11 )"
+RDEPEND="${RDEPEND}
+ || ( x11-proto/xextproto virtual/x11 )"
+
+src_compile() {
+ # We then add the default -Wall from Makefile to CFLAGS
+ emake CFLAGS="${CFLAGS} -Wall" || die "emake failed"
+}
+
+src_install () {
+ dobin wmcpu
+ dodoc ChangeLog README
+}