summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-12 14:39:08 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-12 14:39:08 +0000
commit35b9063d63672e884554e98f73897f29f712e502 (patch)
treecfc6cb32f966e48147634b8ba7377e56c2d5763a /x11-plugins/wmfishtime/files
parentremove useless mpeg USE-flag, add fontconfig USE-flag and correct freetype co... (diff)
downloadgentoo-2-35b9063d63672e884554e98f73897f29f712e502.tar.gz
gentoo-2-35b9063d63672e884554e98f73897f29f712e502.tar.bz2
gentoo-2-35b9063d63672e884554e98f73897f29f712e502.zip
Ported to GTK+-2.0.
(Portage version: 2.1.4)
Diffstat (limited to 'x11-plugins/wmfishtime/files')
-rw-r--r--x11-plugins/wmfishtime/files/digest-wmfishtime-1.24-r13
-rw-r--r--x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch60
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-plugins/wmfishtime/files/digest-wmfishtime-1.24-r1 b/x11-plugins/wmfishtime/files/digest-wmfishtime-1.24-r1
new file mode 100644
index 000000000000..781cad5bd388
--- /dev/null
+++ b/x11-plugins/wmfishtime/files/digest-wmfishtime-1.24-r1
@@ -0,0 +1,3 @@
+MD5 8723b7c6a58b8c41a1dd5973ede4b296 wmfishtime-1.24.tar.gz 21895
+RMD160 9c705351ecbc28e15fd8e3b73712940fdb73baf1 wmfishtime-1.24.tar.gz 21895
+SHA256 7d92889d295558acd8af79f4d74c6fa7c980ac1010b7f0691249a117b34bba07 wmfishtime-1.24.tar.gz 21895
diff --git a/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch b/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch
new file mode 100644
index 000000000000..a2c8342938f5
--- /dev/null
+++ b/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch
@@ -0,0 +1,60 @@
+diff -ur wmfishtime-1.24.orig/fishmon.c wmfishtime-1.24/fishmon.c
+--- wmfishtime-1.24.orig/fishmon.c 2004-05-13 02:55:59.000000000 +0300
++++ wmfishtime-1.24/fishmon.c 2008-01-12 16:19:34.000000000 +0200
+@@ -648,6 +648,7 @@
+
+ /* make a copy for the iconwin - parameters are the same */
+ memcpy(&attri, &attr, sizeof(GdkWindowAttr));
++ attri.window_type = GDK_WINDOW_CHILD;
+
+ sizehints.flags = USSize;
+ sizehints.width = 64;
+@@ -679,7 +680,6 @@
+ wmhints.window_group = win;
+ wmhints.flags =
+ StateHint | IconWindowHint | IconPositionHint | WindowGroupHint;
+- XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
+
+ bm.gc = gdk_gc_new(bm.win);
+
+@@ -693,6 +693,8 @@
+
+ gdk_window_show(bm.win);
+
++ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++
+ #undef MASK
+ } /* make_new_fishmon_dockapp */
+
+diff -ur wmfishtime-1.24.orig/Makefile wmfishtime-1.24/Makefile
+--- wmfishtime-1.24.orig/Makefile 2001-05-26 23:49:41.000000000 +0300
++++ wmfishtime-1.24/Makefile 2008-01-12 16:22:30.000000000 +0200
+@@ -2,11 +2,11 @@
+ DESTDIR =
+
+ # where to install this program
+-PREFIX = $(DESTDIR)/usr/X11R6
++PREFIX = $(DESTDIR)/usr
+
+ # no user serviceable parts below this line
+ # optimization cflags
+-CFLAGS = -O3 -Wall `gtk-config --cflags` ${EXTRA}
++CFLAGS += -Wall `pkg-config gtk+-2.0 --cflags` ${EXTRA}
+ # profiling cflags
+ # CFLAGS=-ansi -pedantic -Wall -pg -O3 `gtk-config --cflags` ${EXTRA} -DPRO
+ # test coverage cflags
+@@ -16,7 +16,7 @@
+ CC = gcc
+ SHELL = sh
+ OBJS = fishmon.o
+-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
++LIBS = `pkg-config gtk+-2.0 --libs`
+ INSTALL = -m 755
+
+ all: wmfishtime
+@@ -30,4 +30,4 @@
+ # You're going to have to be root to do this!
+ install:
+ install $(INSTALL) wmfishtime $(PREFIX)/bin
+- install $(INSTALL) wmfishtime.1 $(PREFIX)/man/man1
++ install $(INSTALL) wmfishtime.1 $(PREFIX)/share/man/man1