summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-06-28 09:09:44 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-06-28 09:09:44 +0000
commita302a5749d28e6cb3e52be19cbd21b63bedec813 (patch)
treef9fbf9f7b928365428368eb5d27f3cdf7b03659e /x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
parentVersion bump. No noteworthy changes. (diff)
downloadgentoo-2-a302a5749d28e6cb3e52be19cbd21b63bedec813.tar.gz
gentoo-2-a302a5749d28e6cb3e52be19cbd21b63bedec813.tar.bz2
gentoo-2-a302a5749d28e6cb3e52be19cbd21b63bedec813.zip
Fix support with gtk+ >= 2.18, bug #310779
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild')
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
new file mode 100644
index 000000000000..6c2845c01dad
--- /dev/null
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfishtime/wmfishtime-1.24-r2.ebuild,v 1.1 2010/06/28 09:09:44 voyageur Exp $
+
+EAPI=3
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gtk.patch
+ epatch "${FILESDIR}"/${P}-no_display.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed."
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc ALL_I_GET_IS_A_GRAY_BOX AUTHORS ChangeLog CODING README
+}