summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-09-05 08:16:55 +0000
committerJustin Lecher <jlec@gentoo.org>2012-09-05 08:16:55 +0000
commit30f1a4f9fd5c90bf6714162458a4c906e7f57b3d (patch)
tree3ff4ae5b02012607f50b4db46213df89d7858ff7 /x11-plugins/wmjsql
parentUse domenu instead insinto + doins to install .desktop files (diff)
downloadgentoo-2-30f1a4f9fd5c90bf6714162458a4c906e7f57b3d.tar.gz
gentoo-2-30f1a4f9fd5c90bf6714162458a4c906e7f57b3d.tar.bz2
gentoo-2-30f1a4f9fd5c90bf6714162458a4c906e7f57b3d.zip
Use domenu instead insinto + doins to install .desktop files
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmjsql')
-rw-r--r--x11-plugins/wmjsql/ChangeLog6
-rw-r--r--x11-plugins/wmjsql/wmjsql-0.5.ebuild20
2 files changed, 15 insertions, 11 deletions
diff --git a/x11-plugins/wmjsql/ChangeLog b/x11-plugins/wmjsql/ChangeLog
index 2d85ade29ca2..dc44cc13d506 100644
--- a/x11-plugins/wmjsql/ChangeLog
+++ b/x11-plugins/wmjsql/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmjsql
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmjsql/ChangeLog,v 1.13 2012/02/15 09:49:12 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmjsql/ChangeLog,v 1.14 2012/09/05 08:16:55 jlec Exp $
+
+ 05 Sep 2012; Justin Lecher <jlec@gentoo.org> wmjsql-0.5.ebuild:
+ Use domenu instead insinto + doins to install .desktop files
15 Feb 2012; Bernard Cafarelli <voyageur@gentoo.org> wmjsql-0.5.ebuild:
Update HOMEPAGE and SRC_URI, thanks Lorenz in bug #394607
@@ -43,4 +46,3 @@
17 Jul 2004; Michele Noberasco <s4t4n@gentoo.org> wmjsql-0.5.ebuild:
Initial import. Thanks to Przemyslaw Maciag. Closes #54558.
-
diff --git a/x11-plugins/wmjsql/wmjsql-0.5.ebuild b/x11-plugins/wmjsql/wmjsql-0.5.ebuild
index e332a66545e6..c5f773cae017 100644
--- a/x11-plugins/wmjsql/wmjsql-0.5.ebuild
+++ b/x11-plugins/wmjsql/wmjsql-0.5.ebuild
@@ -1,19 +1,19 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmjsql/wmjsql-0.5.ebuild,v 1.14 2012/02/15 09:49:12 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmjsql/wmjsql-0.5.ebuild,v 1.15 2012/09/05 08:16:55 jlec Exp $
EAPI=2
-IUSE=""
+inherit eutils
MY_P="${PN}"
-S="${WORKDIR}/${MY_P}"
DESCRIPTION="MySQL monitor dockapp"
-SRC_URI="http://dockapps.windowmaker.org/download.php/id/73/${P}.tar.gz"
HOMEPAGE="http://dockapps.windowmaker.org/file.php/id/42"
+SRC_URI="http://dockapps.windowmaker.org/download.php/id/73/${P}.tar.gz"
-RDEPEND="x11-libs/libX11
+RDEPEND="
+ x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"
DEPEND="${RDEPEND}
@@ -24,14 +24,17 @@ DEPEND="${RDEPEND}
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="ppc sparc x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
src_prepare() {
- sed -i "s/make/\$(MAKE)/g" src/Makefile
+ sed -i "s/make/\$(MAKE)/g" src/Makefile || die
}
src_compile() {
cd "${S}"/src
- make clean
+ emake clean || die
emake CFLAGS="${CFLAGS}" SYSTEM="${LDFLAGS}" || die
}
@@ -43,6 +46,5 @@ src_install() {
cd "${S}"
dodoc CREDITS README TODO
- insinto /usr/share/applications
- doins "${FILESDIR}"/${PN}.desktop
+ domenu "${FILESDIR}"/${PN}.desktop
}