summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2004-07-20 19:19:27 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2004-07-20 19:19:27 +0000
commitb8e80e4dbc8d452b4e8eb10516a9b67618e5bf40 (patch)
tree48a48bfc93191fe3719797fed886dc6a0d978059 /x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
parentdev-python/PyXML-py21 is now dev-python/pyxml-py21 - remove old ebuilds. (diff)
downloadgentoo-2-b8e80e4dbc8d452b4e8eb10516a9b67618e5bf40.tar.gz
gentoo-2-b8e80e4dbc8d452b4e8eb10516a9b67618e5bf40.tar.bz2
gentoo-2-b8e80e4dbc8d452b4e8eb10516a9b67618e5bf40.zip
Add a patch to x11-plugins/wmpinboard 1.0 so that it does not segfault when adding a new note. Closes #43369
Diffstat (limited to 'x11-plugins/wmpinboard/wmpinboard-1.0.ebuild')
-rw-r--r--x11-plugins/wmpinboard/wmpinboard-1.0.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild b/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
index e61b4810ee66..cd8cce40f85d 100644
--- a/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
+++ b/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild,v 1.11 2004/06/24 23:15:51 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpinboard/wmpinboard-1.0.ebuild,v 1.12 2004/07/20 19:19:27 s4t4n Exp $
+
+inherit eutils
IUSE=""
DESCRIPTION="Window Maker dock applet resembling a miniature pinboard."
@@ -13,12 +15,20 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="x86 sparc alpha amd64 ~ppc"
-src_compile() {
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/wmpinboard-1.0-segfault.patch
+}
+
+src_compile()
+{
econf || die "econf failed"
emake || die "emake failed"
}
-src_install () {
+src_install ()
+{
make DESTDIR=${D} install-strip || die "install failed"
}
-