summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-07-28 07:54:32 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-07-28 07:54:32 +0000
commit73a8ad016192597b7b90870bfd25d52f8c6fcd65 (patch)
treea8b4c9e8c930dece1a5144783d9c7605f34eda07 /x11-plugins
parentFix DESCRIPTION. (diff)
downloadgentoo-2-73a8ad016192597b7b90870bfd25d52f8c6fcd65.tar.gz
gentoo-2-73a8ad016192597b7b90870bfd25d52f8c6fcd65.tar.bz2
gentoo-2-73a8ad016192597b7b90870bfd25d52f8c6fcd65.zip
Revision bump, dependancy on gtk+-1.2 is now optional. You won't get
the graphical configuration editor without it, but at least gtk+-1.2 is not necessary anymore to build this package. (Portage version: 2.1.4.4)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmpop/ChangeLog10
-rw-r--r--x11-plugins/wmpop/wmpop-0.53-r1.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/x11-plugins/wmpop/ChangeLog b/x11-plugins/wmpop/ChangeLog
index af50d6ddaaf3..19a1751ab1a5 100644
--- a/x11-plugins/wmpop/ChangeLog
+++ b/x11-plugins/wmpop/ChangeLog
@@ -1,8 +1,14 @@
# ChangeLog for x11-plugins/wmpop
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpop/ChangeLog,v 1.11 2008/07/28 07:39:42 s4t4n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpop/ChangeLog,v 1.12 2008/07/28 07:54:32 s4t4n Exp $
- 28 Jul 2008; Michele Noberasco <s4t4n@gentoo.org> wmpop-0.53.ebuild:
+*wmpop-0.53-r1 (28 Jul 2008)
+
+ 28 Jul 2008; Michele Noberasco <s4t4n@gentoo.org> wmpop-0.53-r1.ebuild:
+ Revision bump, dependancy on gtk+-1.2 is now optional. You won't get
+ the graphical configuration editor without it, but at least gtk+-1.2
+ is not necessary anymore to build this package.
+ wmpop-0.53.ebuild:
added libXpm to runtime dependancies. Closes bug #233023.
13 May 2008; Michele Noberasco <s4t4n@gentoo.org> wmpop-0.53.ebuild:
diff --git a/x11-plugins/wmpop/wmpop-0.53-r1.ebuild b/x11-plugins/wmpop/wmpop-0.53-r1.ebuild
new file mode 100644
index 000000000000..8a0c1fc644b3
--- /dev/null
+++ b/x11-plugins/wmpop/wmpop-0.53-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmpop/wmpop-0.53-r1.ebuild,v 1.1 2008/07/28 07:54:32 s4t4n Exp $
+
+IUSE="gtk"
+
+DESCRIPTION="WMpop is a Window Maker DockApp for monitoring a local (mbox format) or POP3 and APOP mailbox."
+SRC_URI="http://jsautret.free.fr/wmpop/${P}.tar.gz"
+HOMEPAGE="http://wmpop.sautret.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~sparc ~x86"
+
+RDEPEND="media-sound/esound
+ x11-libs/libXpm
+ gtk? ( =x11-libs/gtk+-1.2* )"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison"
+
+src_compile()
+{
+ econf \
+ `use_enable gtk gtkgui` \
+ || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc AUTHORS README ChangeLog NEWS TODO THANKS
+}