summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRomain Perier <mrpouet@gentoo.org>2009-11-01 14:55:38 +0000
committerRomain Perier <mrpouet@gentoo.org>2009-11-01 14:55:38 +0000
commit903176aea45a5d6b2556f1d85e76990e84842d22 (patch)
tree4e314769ecf7cecc1256aff48e11f0a8462f5fcd /x11-plugins
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-903176aea45a5d6b2556f1d85e76990e84842d22.tar.gz
gentoo-2-903176aea45a5d6b2556f1d85e76990e84842d22.tar.bz2
gentoo-2-903176aea45a5d6b2556f1d85e76990e84842d22.zip
Fix two QA , replace $(use_enable gnome gconf) by $(use_enable gnome schemas). Add inheritance from gnome2-utils.eclass in order to install gconf schemas correctly. New revision. Many thanks to scarab
(Portage version: 2.2_rc48/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/compiz-plugins-extra/ChangeLog10
-rw-r--r--x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4-r1.ebuild64
2 files changed, 73 insertions, 1 deletions
diff --git a/x11-plugins/compiz-plugins-extra/ChangeLog b/x11-plugins/compiz-plugins-extra/ChangeLog
index 47db547afca1..989faba4dd6b 100644
--- a/x11-plugins/compiz-plugins-extra/ChangeLog
+++ b/x11-plugins/compiz-plugins-extra/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/compiz-plugins-extra
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.7 2009/10/15 17:16:55 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/ChangeLog,v 1.8 2009/11/01 14:55:38 mrpouet Exp $
+
+*compiz-plugins-extra-0.8.4-r1 (01 Nov 2009)
+
+ 01 Nov 2009; Romain Perier <mrpouet@gentoo.org>
+ +compiz-plugins-extra-0.8.4-r1.ebuild:
+ Fix two QA , replace $(use_enable gnome gconf) by $(use_enable gnome
+ schemas). Add inheritance from gnome2-utils.eclass in order to install
+ gconf schemas correctly. New revision. Many thanks to scarab.
*compiz-plugins-extra-0.8.4 (15 Oct 2009)
diff --git a/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4-r1.ebuild b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4-r1.ebuild
new file mode 100644
index 000000000000..440ab57b4037
--- /dev/null
+++ b/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/compiz-plugins-extra/compiz-plugins-extra-0.8.4-r1.ebuild,v 1.1 2009/11/01 14:55:38 mrpouet Exp $
+
+EAPI="2"
+
+inherit autotools eutils gnome2-utils
+
+DESCRIPTION="Compiz Fusion Window Decorator Extra Plugins"
+HOMEPAGE="http://www.compiz.org/"
+SRC_URI="http://releases.compiz.org/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="gnome"
+
+RDEPEND="
+ !x11-plugins/compiz-fusion-plugins-extra
+ >=gnome-base/librsvg-2.14.0
+ media-libs/jpeg
+ ~x11-libs/compiz-bcop-${PV}
+ ~x11-plugins/compiz-plugins-main-${PV}
+ ~x11-wm/compiz-${PV}
+"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.19
+ >=sys-devel/gettext-0.15
+ x11-libs/cairo
+ gnome? ( gnome-base/gconf )
+"
+
+src_prepare() {
+ use gnome || {
+ epatch "${FILESDIR}"/${PN}-no-gconf.patch
+
+ # required to apply the above patch
+ intltoolize --copy --force || die "intltoolize failed"
+ eautoreconf || die "eautoreconf failed"
+ }
+}
+
+src_configure() {
+ econf --disable-dependency-tracking \
+ $(use_enable gnome schemas)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
+
+pkg_preinst() {
+ if use gnome; then
+ gnome2_gconf_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gnome; then
+ gnome2_gconf_install
+ fi
+}