summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-20 17:05:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-20 17:05:34 +0000
commita09f26a26e27198cf12555b7b5e4c16d2897d8fe (patch)
tree33efd2dd2f3f00fac15172d430c3c8788c421448 /x11-plugins
parentFixing as-needed issues wrt bug 294971, provide shared libs. Thanks Diego for... (diff)
downloadgentoo-2-a09f26a26e27198cf12555b7b5e4c16d2897d8fe.tar.gz
gentoo-2-a09f26a26e27198cf12555b7b5e4c16d2897d8fe.tar.bz2
gentoo-2-a09f26a26e27198cf12555b7b5e4c16d2897d8fe.zip
Fix building with -Wl,--as-needed wrt #320795 by Kacper Kowalik.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmauda/ChangeLog8
-rw-r--r--x11-plugins/wmauda/files/wmauda-0.7-asneeded.patch24
-rw-r--r--x11-plugins/wmauda/wmauda-0.7.ebuild15
3 files changed, 40 insertions, 7 deletions
diff --git a/x11-plugins/wmauda/ChangeLog b/x11-plugins/wmauda/ChangeLog
index 0cc254aa508a..ab1fcbbc036e 100644
--- a/x11-plugins/wmauda/ChangeLog
+++ b/x11-plugins/wmauda/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmauda
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/ChangeLog,v 1.14 2009/08/16 09:15:27 betelgeuse Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/ChangeLog,v 1.15 2010/06/20 17:05:34 ssuominen Exp $
+
+ 20 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> wmauda-0.7.ebuild,
+ +files/wmauda-0.7-asneeded.patch:
+ Fix building with -Wl,--as-needed wrt #320795 by Kacper Kowalik.
16 Aug 2009; Petteri Räty <betelgeuse@gentoo.org> wmauda-0.7.ebuild:
Raise audacious dependency to >=1.5 so we can drop the built_with_use
diff --git a/x11-plugins/wmauda/files/wmauda-0.7-asneeded.patch b/x11-plugins/wmauda/files/wmauda-0.7-asneeded.patch
new file mode 100644
index 000000000000..e9aaabb13332
--- /dev/null
+++ b/x11-plugins/wmauda/files/wmauda-0.7-asneeded.patch
@@ -0,0 +1,24 @@
+Fixing build with as-needed, respecting LDFLAGS
+
+http://bugs.gentoo.org/show_bug.cgi?id=320795
+
+--- Makefile
++++ Makefile
+@@ -7,14 +7,14 @@
+ PIXMAP_DIR := $(PREFIX)/share/pixmaps
+ MANPAGE_DIR := $(PREFIX)/share/man/man1
+
+-CFLAGS += $(shell pkg-config audacious --cflags) $(shell pkg-config dbus-1 --cflags)
+-LIBS := $(shell pkg-config audacious --libs) $(shell pkg-config dbus-1 --libs)
++CFLAGS += $(shell pkg-config audclient --cflags) $(shell pkg-config dbus-1 --cflags)
++LIBS := $(shell pkg-config audclient --libs) $(shell pkg-config dbus-1 --libs)
+
+ OBJS = wmauda.o
+ HEADERS = config.h dock-master.xpm
+
+ wmauda: $(OBJS) $(HEADERS)
+- $(CC) -o wmauda $(OBJS) $(CFLAGS) $(LIBS)
++ $(CC) $(LDFLAGS) -o wmauda $(OBJS) $(CFLAGS) $(LIBS)
+
+ all: wmauda
+
diff --git a/x11-plugins/wmauda/wmauda-0.7.ebuild b/x11-plugins/wmauda/wmauda-0.7.ebuild
index 459a8e4f5605..88b02602e071 100644
--- a/x11-plugins/wmauda/wmauda-0.7.ebuild
+++ b/x11-plugins/wmauda/wmauda-0.7.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/wmauda-0.7.ebuild,v 1.6 2009/08/16 09:15:27 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmauda/wmauda-0.7.ebuild,v 1.7 2010/06/20 17:05:34 ssuominen Exp $
+EAPI=2
inherit eutils toolchain-funcs
DESCRIPTION="Dockable applet for WindowMaker that controls Audacious."
@@ -15,18 +16,22 @@ IUSE=""
RDEPEND="dev-libs/dbus-glib
x11-libs/libX11
- >=x11-libs/gtk+-2
+ x11-libs/gtk+:2
>=media-sound/audacious-1.5"
DEPEND="${RDEPEND}
x11-proto/xproto
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
src_compile() {
tc-export CC
- emake || die "emake failed."
+ emake || die
}
src_install () {
- emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed."
+ emake DESTDIR="${D}" PREFIX="/usr" install || die
dodoc AUTHORS README
}