summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:36:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:36:13 +0000
commitcd478499ae09c75419a1daa0496c148263b1ecf9 (patch)
treec4a817f6278464ea6ac84fa644ec91a41f57cdd4 /x11-plugins
parentUse EAPI5 instead of EAPI1. (diff)
downloadgentoo-2-cd478499ae09c75419a1daa0496c148263b1ecf9.tar.gz
gentoo-2-cd478499ae09c75419a1daa0496c148263b1ecf9.tar.bz2
gentoo-2-cd478499ae09c75419a1daa0496c148263b1ecf9.zip
Use EAPI5 instead of EAPI1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmmaiload/ChangeLog9
-rw-r--r--x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild33
2 files changed, 24 insertions, 18 deletions
diff --git a/x11-plugins/wmmaiload/ChangeLog b/x11-plugins/wmmaiload/ChangeLog
index 9c545c6236dc..dc9a480a1c5d 100644
--- a/x11-plugins/wmmaiload/ChangeLog
+++ b/x11-plugins/wmmaiload/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/wmmaiload
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/ChangeLog,v 1.35 2012/05/05 05:12:03 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/ChangeLog,v 1.36 2014/04/07 19:36:13 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> wmmaiload-2.2.1-r1.ebuild:
+ Use EAPI5 instead of EAPI1.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> wmmaiload-2.2.1-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -134,5 +137,3 @@
ChangeLog, files/digest-wmmaiload-0.6.0 :
Initial import thanks to Autobot.
-
-
diff --git a/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild b/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild
index 3b4622538916..822213bce9ff 100644
--- a/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild
+++ b/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild,v 1.9 2012/05/05 05:12:03 jdhore Exp $
-
-EAPI="1"
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmaiload/wmmaiload-2.2.1-r1.ebuild,v 1.10 2014/04/07 19:36:13 ssuominen Exp $
+EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="dockapp that monitors one or more mailboxes."
@@ -20,21 +19,27 @@ RDEPEND="x11-libs/gtk+:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-gtk.patch
- epatch "${FILESDIR}"/${P}-checkthread.patch
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gtk.patch \
+ "${FILESDIR}"/${P}-checkthread.patch
+}
+
+src_configure() {
+ # The ./configure script is not autoconf based, therefore don't use econf:
+ ./configure -p /usr || die
}
src_compile() {
- ./configure -p /usr || die "configure failed."
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
- DEBUG_LDFLAGS="" LDFLAGS="${LDFLAGS}" \
- DEBUG_CFLAGS="" || die "emake failed."
+ emake \
+ CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ DEBUG_LDFLAGS="" \
+ LDFLAGS="${LDFLAGS}" \
+ DEBUG_CFLAGS=""
}
-src_install () {
+src_install() {
dobin ${PN}/${PN} ${PN}-config/${PN}-config
doman doc/*.1
dodoc AUTHORS ChangeLog FAQ NEWS README THANKS TODO doc/sample.${PN}rc