summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Shepherd <masterdriverz@gentoo.org>2006-12-08 22:53:43 +0000
committerCharlie Shepherd <masterdriverz@gentoo.org>2006-12-08 22:53:43 +0000
commit9eba7e74feef47572092ee602fb969b3f6821d7a (patch)
tree49014c31d4d4bc51057da7969250fe4cc72c6c35 /x11-terms/root-tail/root-tail-1.2-r2.ebuild
parentVersion bump. Includes various bugfixes across the board, and support for the (diff)
downloadgentoo-2-9eba7e74feef47572092ee602fb969b3f6821d7a.tar.gz
gentoo-2-9eba7e74feef47572092ee602fb969b3f6821d7a.tar.bz2
gentoo-2-9eba7e74feef47572092ee602fb969b3f6821d7a.zip
Add libX11 and xproto deps for bug 153603, thanks to Patrick Lauer for reporting + remove old versions
(Portage version: 2.1.2_rc2-r2)
Diffstat (limited to 'x11-terms/root-tail/root-tail-1.2-r2.ebuild')
-rw-r--r--x11-terms/root-tail/root-tail-1.2-r2.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/x11-terms/root-tail/root-tail-1.2-r2.ebuild b/x11-terms/root-tail/root-tail-1.2-r2.ebuild
index aae37959f578..bec4af126087 100644
--- a/x11-terms/root-tail/root-tail-1.2-r2.ebuild
+++ b/x11-terms/root-tail/root-tail-1.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/root-tail-1.2-r2.ebuild,v 1.10 2006/09/11 20:58:37 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/root-tail/root-tail-1.2-r2.ebuild,v 1.11 2006/12/08 22:53:43 masterdriverz Exp $
inherit eutils flag-o-matic
@@ -13,11 +13,12 @@ SLOT="0"
KEYWORDS="alpha amd64 ppc ppc64 ~sparc x86"
IUSE="kde debug"
-RDEPEND="|| ( x11-libs/libXext virtual/x11 )"
-DEPEND=">=sys-apps/sed-4
- || ( ( x11-misc/imake
+RDEPEND="|| ( ( x11-libs/libXext x11-libs/libX11 ) virtual/x11 )"
+DEPEND="|| ( ( x11-misc/imake
app-text/rman
x11-misc/gccmakedep
+ x11-libs/libX11
+ x11-proto/xproto
)
virtual/x11
)"
@@ -30,7 +31,7 @@ src_unpack() {
src_compile() {
xmkmf -a
- sed -i 's|/usr/X11R6/bin|/usr/bin|' Makefile || die "sed Makefile failed"
+ sed -i 's:/usr/X11R6/bin:/usr/bin:' Makefile || die "sed Makefile failed"
use debug && append-flags -DDEBUG
emake || die "emake failed"
}