summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2005-03-14 15:38:14 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2005-03-14 15:38:14 +0000
commitb73347dbd70a37fe11f409522105c2beba7e477f (patch)
treec46ed8bfe51e877f2ff3e8fbc91df95a9709da60 /x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild
parentStable on x86 and amd64 (because Stuart already committed the DEPEND change t... (diff)
downloadgentoo-2-b73347dbd70a37fe11f409522105c2beba7e477f.tar.gz
gentoo-2-b73347dbd70a37fe11f409522105c2beba7e477f.tar.bz2
gentoo-2-b73347dbd70a37fe11f409522105c2beba7e477f.zip
New version, bug #84680
(Portage version: 2.0.51.19 small furry bundle of death edition)
Diffstat (limited to 'x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild')
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild89
1 files changed, 89 insertions, 0 deletions
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild
new file mode 100644
index 000000000000..cc6093882b7a
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-5.3.ebuild,v 1.1 2005/03/14 15:38:14 ciaranm Exp $
+
+inherit 64-bit eutils flag-o-matic
+
+IUSE="xgetdefault tabs"
+
+DESCRIPTION="rxvt clone with XFT and Unicode support"
+HOMEPAGE="http://software.schmorp.de/"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc"
+
+DEPEND="virtual/libc
+ dev-util/pkgconfig
+ sys-devel/libtool
+ virtual/x11
+ dev-lang/perl
+ tabs? ( dev-perl/gtk2-perl )"
+
+pkg_preinst() {
+ filter-flags -mno-accumulate-outgoing-args
+ replace-flags -Os -O2
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ local tdir=/usr/share/terminfo
+ sed -i -e \
+ "s~@TIC@ \(etc/rxvt\)~@TIC@ -o ${D}/${tdir} \1~" \
+ doc/Makefile.in
+ sed -i -e \
+ "s:-g -O3:${CFLAGS}:" \
+ configure
+}
+
+src_compile() {
+ econf \
+ --enable-everything \
+ --enable-rxvt-scroll \
+ --enable-next-scroll \
+ --enable-xterm-scroll \
+ --enable-transparency \
+ --enable-xpm-background \
+ --enable-fading \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-mousewheel \
+ --enable-slipwheeling \
+ --enable-smart-resize \
+ --enable-ttygid \
+ --enable-256-color \
+ --enable-xim \
+ --enable-shared \
+ --enable-keepscrolling \
+ --enable-xft \
+ `use_enable xgetdefault` \
+ --disable-text-blink \
+ --disable-menubar || die
+
+ emake || die
+
+ if useq tabs ; then
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ ${S}/doc/rxvt-tabbed || die "tabs sed failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc README.FAQ Changes
+ cd ${S}/doc
+ dodoc README* changes.txt etc/*
+
+ if useq tabs ; then
+ newbin rxvt-tabbed urxvt-tabbed
+ fi
+}
+
+pkg_postinst() {
+ einfo "urxvt now always uses TERM=rxvt-unicode so that the"
+ einfo "upstream-supplied terminfo files can be used."
+}