summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2013-11-08 15:56:03 +0000
committerAlex Alexander <wired@gentoo.org>2013-11-08 15:56:03 +0000
commit58e5871d4a8ec7755502ae50aca45aa033556511 (patch)
tree362eb2deb74607e67a4dcb61cc93e820166ed0d7 /x11-terms/rxvt-unicode
parentStable for HPPA (bug #490126). (diff)
downloadgentoo-2-58e5871d4a8ec7755502ae50aca45aa033556511.tar.gz
gentoo-2-58e5871d4a8ec7755502ae50aca45aa033556511.tar.bz2
gentoo-2-58e5871d4a8ec7755502ae50aca45aa033556511.zip
updated secondary-wheel patch for rxvt-unicode-9.19 - bug #490686
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EB9B4AFA)
Diffstat (limited to 'x11-terms/rxvt-unicode')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog6
-rw-r--r--x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-secondary-wheel.patch123
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild4
3 files changed, 130 insertions, 3 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index cbed1a842245..29b1ad027138 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.249 2013/11/06 16:11:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.250 2013/11/08 15:56:03 wired Exp $
+
+ 08 Nov 2013; Alex Alexander <wired@gentoo.org> rxvt-unicode-9.19.ebuild,
+ +files/rxvt-unicode-9.19-secondary-wheel.patch:
+ updated secondary-wheel patch for rxvt-unicode-9.19 - bug #490686
*rxvt-unicode-9.19 (06 Nov 2013)
diff --git a/x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-secondary-wheel.patch b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-secondary-wheel.patch
new file mode 100644
index 000000000000..3a4d4a409814
--- /dev/null
+++ b/x11-terms/rxvt-unicode/files/rxvt-unicode-9.19-secondary-wheel.patch
@@ -0,0 +1,123 @@
+secondary wheel support:
+when using the mouse wheel, if you’re on secondary screen then no scrolling
+will occur, and instead some (3, to be exact) “fake” keystrokes will be sent to
+the running application.
+
+patch by jacky
+i.am.jack.mail@gmail.com
+http://lists.schmorp.de/pipermail/rxvt-unicode/2011q4/001491.html
+
+diff -r d5f9ea7306c4 -r cca1997c1a85 doc/rxvt.1.pod
+--- a/doc/rxvt.1.pod Wed Dec 21 22:59:04 2011 +0100
++++ b/doc/rxvt.1.pod Wed Dec 21 23:01:28 2011 +0100
+@@ -455,6 +455,11 @@
+ Turn on/off secondary screen scroll (default enabled); resource
+ B<secondaryScroll>.
+
++=item B<-ssw>|B<+ssw>
++
++Turn on/off secondary screen wheel support (default disabled); resource
++B<secondaryWheel>.
++
+ =item B<-hold>|B<+hold>
+
+ Turn on/off hold window after exit support. If enabled, @@RXVT_NAME@@
+@@ -1167,6 +1172,13 @@
+ scrollback buffer and, when secondaryScreen is off, switching
+ to/from the secondary screen will instead scroll the screen up.
+
++=item B<secondaryWheel:> I<boolean>
++
++Turn on/off secondary wheel (default disabled). If enabled, when on
++secondary screen, using the mouse wheel will not scroll in the buffer
++but instead send 3 "fake" keystrokes (Up/Down arrow) to the running
++application (allows e.g. natural scrolling in B<man>, B<less>, etc).
++
+ =item B<hold>: I<boolean>
+
+ Turn on/off hold window after exit support. If enabled, @@RXVT_NAME@@
+diff -r d5f9ea7306c4 -r cca1997c1a85 src/command.C
+--- a/src/command.C Wed Dec 21 22:59:04 2011 +0100
++++ b/src/command.C Wed Dec 21 23:01:28 2011 +0100
+@@ -2197,10 +2197,46 @@
+ }
+ else
+ # endif
++#ifndef NO_SECONDARY_SCREEN
+ {
+- scr_page (dirn, lines);
+- scrollBar.show (1);
++ /* on SECONDARY screen, we send "fake" UP/DOWN keys instead
++ * (this allows to scroll within man, less, etc) */
++ if (option (Opt_secondaryWheel) && current_screen != PRIMARY)
++ {
++ XKeyEvent event;
++ event.display = ev.display;
++ event.window = ev.window;
++ event.root = ev.root;
++ event.subwindow = ev.subwindow;
++ event.time = ev.time;
++ event.x = ev.x;
++ event.y = ev.y;
++ event.x_root = ev.x_root;
++ event.y_root = ev.y_root;
++ event.same_screen = ev.same_screen;
++ event.state = 0;
++ event.keycode = XKeysymToKeycode(ev.display,
++ (dirn == UP) ? XK_Up : XK_Down);
++ for (lines = 0; lines < 3; ++lines)
++ {
++ event.type = KeyPress;
++ XSendEvent (event.display, event.window, True,
++ KeyPressMask, (XEvent *) &event);
++ event.type = KeyRelease;
++ XSendEvent (event.display, event.window, True,
++ KeyPressMask, (XEvent *) &event);
++ }
++ }
++ /* on PRIMARY screen, we scroll in the buffer */
++ else
++#endif
++ {
++ scr_page (dirn, lines);
++ scrollBar.show (1);
++ }
++#ifndef NO_SECONDARY_SCREEN
+ }
++#endif
+ }
+ break;
+ #endif
+diff -r d5f9ea7306c4 -r cca1997c1a85 src/optinc.h
+--- a/src/optinc.h Wed Dec 21 22:59:04 2011 +0100
++++ b/src/optinc.h Wed Dec 21 23:01:28 2011 +0100
+@@ -26,6 +26,7 @@
+ def(cursorBlink)
+ def(secondaryScreen)
+ def(secondaryScroll)
++ def(secondaryWheel)
+ def(pastableTabs)
+ def(cursorUnderline)
+ #if ENABLE_FRILLS
+diff -r d5f9ea7306c4 -r cca1997c1a85 src/rsinc.h
+--- a/src/rsinc.h Wed Dec 21 22:59:04 2011 +0100
++++ b/src/rsinc.h Wed Dec 21 23:01:28 2011 +0100
+@@ -102,6 +102,7 @@
+ #ifndef NO_SECONDARY_SCREEN
+ def (secondaryScreen)
+ def (secondaryScroll)
++ def (secondaryWheel)
+ #endif
+ #ifdef OFF_FOCUS_FADING
+ def (fade)
+diff -r d5f9ea7306c4 -r cca1997c1a85 src/xdefaults.C
+--- a/src/xdefaults.C Wed Dec 21 22:59:04 2011 +0100
++++ b/src/xdefaults.C Wed Dec 21 23:01:28 2011 +0100
+@@ -261,6 +261,7 @@
+ #ifndef NO_SECONDARY_SCREEN
+ BOOL (Rs_secondaryScreen, "secondaryScreen", "ssc", Opt_secondaryScreen, 0, "enable secondary screen"),
+ BOOL (Rs_secondaryScroll, "secondaryScroll", "ssr", Opt_secondaryScroll, 0, "enable secondary screen scroll"),
++ BOOL (Rs_secondaryWheel, "secondaryWheel", "ssw", Opt_secondaryWheel, 0, "enable secondary screen wheel"),
+ #endif
+ #if ENABLE_PERL
+ RSTRG (Rs_perl_lib, "perl-lib", "string"), //, "colon-separated directories with extension scripts"),TODO
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild
index 3b25bef304a6..433edcfb79ac 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild,v 1.1 2013/11/06 16:11:32 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.19.ebuild,v 1.2 2013/11/08 15:56:03 wired Exp $
EAPI=4
inherit autotools eutils
@@ -62,7 +62,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-9.05_no-MOTIF-WM-INFO.patch
# support for wheel scrolling on secondary screens
- use secondary-wheel && epatch "${FILESDIR}"/${PN}-9.14-secondary-wheel.patch
+ use secondary-wheel && epatch "${FILESDIR}"/${PN}-9.19-secondary-wheel.patch
# ctrl-l buffer fix
use buffer-on-clear && epatch "${FILESDIR}"/${PN}-9.14-clear.patch