summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2006-01-02 20:08:08 +0000
committerMamoru Komachi <usata@gentoo.org>2006-01-02 20:08:08 +0000
commit928d4f5582519c052a95227fd27b3c771a8d2012 (patch)
tree185833e58b1636abff18ab85d4e0b8d5d5dd1738 /x11-terms/rxvt/rxvt-2.7.10-r3.ebuild
parenttidy (diff)
downloadgentoo-2-928d4f5582519c052a95227fd27b3c771a8d2012.tar.gz
gentoo-2-928d4f5582519c052a95227fd27b3c771a8d2012.tar.bz2
gentoo-2-928d4f5582519c052a95227fd27b3c771a8d2012.zip
Updated for modular X; bug #115992.
(Portage version: 2.0.53)
Diffstat (limited to 'x11-terms/rxvt/rxvt-2.7.10-r3.ebuild')
-rw-r--r--x11-terms/rxvt/rxvt-2.7.10-r3.ebuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild b/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild
index efce325b6347..9fc374d33fa5 100644
--- a/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild
+++ b/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild,v 1.3 2005/12/25 15:43:04 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/rxvt-2.7.10-r3.ebuild,v 1.4 2006/01/02 20:08:08 usata Exp $
inherit eutils flag-o-matic libtool
@@ -15,9 +15,21 @@ SLOT="0"
KEYWORDS="~x86 ~ppc ~alpha ~sparc ~mips ~amd64 ~ppc64"
IUSE="motif cjk xgetdefault linuxkeys"
-DEPEND="virtual/libc
- virtual/x11
+RDEPEND="virtual/libc
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext
+ )
+ virtual/x11
+ )
motif? ( x11-libs/openmotif )"
+DEPEND="${RDEPEND}
+ || ( (
+ x11-proto/xproto
+ )
+ virtual/x11
+ )"
src_unpack() {
unpack ${P}.tar.gz
@@ -32,7 +44,7 @@ src_unpack() {
fi
fi
- uclibctoolize
+ elibtoolize
}
src_compile() {