summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Dack <tad@gentoo.org>2003-09-12 15:35:01 +0000
committerTroy Dack <tad@gentoo.org>2003-09-12 15:35:01 +0000
commit2f59e98fa73ed023f2bc0746e12c96f7aff726ba (patch)
tree77ba335cfac1f4c315647b2addfdb1da26efdd6e /x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild
parentVersion Bump. Closes Bug #26109. (diff)
downloadgentoo-2-2f59e98fa73ed023f2bc0746e12c96f7aff726ba.tar.gz
gentoo-2-2f59e98fa73ed023f2bc0746e12c96f7aff726ba.tar.bz2
gentoo-2-2f59e98fa73ed023f2bc0746e12c96f7aff726ba.zip
Version Bump. Closes Bug #26109.
Diffstat (limited to 'x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild')
-rw-r--r--x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild b/x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild
new file mode 100644
index 000000000000..ef22a5772701
--- /dev/null
+++ b/x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/golden-xcursors/golden-xcursors-0.8.ebuild,v 1.1 2003/09/12 15:34:17 tad Exp $
+
+MY_P="5507-Golden-XCursors-3D-${PV}"
+DESCRIPTION="A high quality set of Xfree 4.3.0 animated mouse cursors"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=5507"
+SRC_URI="http://www.kde-look.org/content/files/$MY_P.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=x11-base/xfree-4.3.0-r2"
+
+src_install() {
+ mkdir -p ${D}/usr/share/cursors/xfree/Gold/cursors/
+ cp -d ${WORKDIR}/${MY_P:5}/Gold/cursors/* ${D}/usr/share/cursors/xfree/Gold/cursors/ || die
+ dodoc ${WORKDIR}/${MY_P:5}/{COPYING,README}
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ einfo "and add the following line:"
+ einfo "Xcursor.theme: Gold"
+ einfo ""
+ einfo "Also, you can change the size by adding a line like:"
+ einfo "Xcursor.size: 48"
+ einfo ""
+ einfo ""
+ einfo "To globally use this set of mouse cursors edit the file:"
+ einfo " /usr/share/cursors/xfree/default/index.theme"
+ einfo "and change the line:"
+ einfo " Inherits=[current setting]"
+ einfo "to"
+ einfo " Inherits=Gold"
+ einfo "Note this will be overruled by a user's ~/.Xdefaults file"
+ einfo ""
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your XF86Config:"
+ ewarn "Option \"HWCursor\" \"false\""
+}