summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-08-02 11:50:49 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-08-02 11:50:49 +0000
commitbcf5d50846fc95e44ff703523859422b6315a50c (patch)
treebcb7b22c9f6345890e08d1126ad7d633d0f746fd /x11-themes/gtk-engines-notif2
parentStable on x86 due security bug #100398 (diff)
downloadgentoo-2-bcf5d50846fc95e44ff703523859422b6315a50c.tar.gz
gentoo-2-bcf5d50846fc95e44ff703523859422b6315a50c.tar.bz2
gentoo-2-bcf5d50846fc95e44ff703523859422b6315a50c.zip
Don't inherit from gtk-engines2.eclass
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-themes/gtk-engines-notif2')
-rw-r--r--x11-themes/gtk-engines-notif2/ChangeLog12
-rw-r--r--x11-themes/gtk-engines-notif2/Manifest6
-rw-r--r--x11-themes/gtk-engines-notif2/files/digest-gtk-engines-notif2-1.0-r11
-rw-r--r--x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild37
-rw-r--r--x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0.ebuild13
5 files changed, 60 insertions, 9 deletions
diff --git a/x11-themes/gtk-engines-notif2/ChangeLog b/x11-themes/gtk-engines-notif2/ChangeLog
index 4ddc479ebf61..baaea1e2d80c 100644
--- a/x11-themes/gtk-engines-notif2/ChangeLog
+++ b/x11-themes/gtk-engines-notif2/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-themes/gtk-engines-notif2
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-notif2/ChangeLog,v 1.7 2004/09/15 13:06:39 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-notif2/ChangeLog,v 1.8 2005/08/02 11:50:49 leonardop Exp $
+
+*gtk-engines-notif2-1.0-r1 (02 Aug 2005)
+
+ 02 Aug 2005; Leonardo Boshell <leonardop@gentoo.org>
+ gtk-engines-notif2-1.0-r1.ebuild:
+ Added 'static' USE flag.
+
+ 02 Aug 2005; Leonardo Boshell <leonardop@gentoo.org>
+ gtk-engines-notif2-1.0.ebuild:
+ Don't inherit from gtk-engines2.eclass.
15 Sep 2004; Gustavo Zacarias <gustavoz@gentoo.org>
gtk-engines-notif2-1.0.ebuild:
diff --git a/x11-themes/gtk-engines-notif2/Manifest b/x11-themes/gtk-engines-notif2/Manifest
index 8745c58b7405..2519fd5bc420 100644
--- a/x11-themes/gtk-engines-notif2/Manifest
+++ b/x11-themes/gtk-engines-notif2/Manifest
@@ -1,4 +1,6 @@
-MD5 8d433d1b19ac16e29913a660788c522d ChangeLog 983
-MD5 153acf8eb9ab58985a5053fedc1e5de5 gtk-engines-notif2-1.0.ebuild 751
+MD5 7db1c754ac8ef0902c0aa9ff966337fd ChangeLog 1275
+MD5 ebe63643ca2f88245e726bfc89f3098c gtk-engines-notif2-1.0.ebuild 750
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
+MD5 c49100897d0e3a86612e93d08f99b3f9 gtk-engines-notif2-1.0-r1.ebuild 897
MD5 75f60267e32e89d77e6fea38ca784364 files/digest-gtk-engines-notif2-1.0 63
+MD5 75f60267e32e89d77e6fea38ca784364 files/digest-gtk-engines-notif2-1.0-r1 63
diff --git a/x11-themes/gtk-engines-notif2/files/digest-gtk-engines-notif2-1.0-r1 b/x11-themes/gtk-engines-notif2/files/digest-gtk-engines-notif2-1.0-r1
new file mode 100644
index 000000000000..db23e79aad03
--- /dev/null
+++ b/x11-themes/gtk-engines-notif2/files/digest-gtk-engines-notif2-1.0-r1
@@ -0,0 +1 @@
+MD5 e117977d4d15e070da519b431045b701 notif210-1.2.tar.gz 98677
diff --git a/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild b/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild
new file mode 100644
index 000000000000..993f092e9637
--- /dev/null
+++ b/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0-r1.ebuild,v 1.1 2005/08/02 11:50:49 leonardop Exp $
+
+inherit gnuconfig
+
+DESCRIPTION="GTK+1 Notif2 Theme Engine"
+HOMEPAGE="http://themes.freshmeat.net/projects/notif210/"
+SRC_URI="http://download.freshmeat.net/themes/notif210/notif210-1.2.tar.gz"
+KEYWORDS="~x86 ~alpha ~ppc ~amd64 ~sparc"
+LICENSE="GPL-2"
+SLOT="1"
+IUSE="static"
+
+DEPEND="=x11-libs/gtk+-1.2*"
+
+S=${WORKDIR}/notif2-${PV}
+
+src_unpack() {
+ unpack ${A}
+ if [[ ${ARCH} == "amd64" ]]; then
+ gnuconfig_update
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable static)"
+
+ econf $myconf || die "Configuration failed"
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0.ebuild b/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0.ebuild
index e24f7ec7c494..e0b59a91b950 100644
--- a/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0.ebuild
+++ b/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0.ebuild,v 1.9 2004/09/15 13:06:39 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-notif2/gtk-engines-notif2-1.0.ebuild,v 1.10 2005/08/02 11:50:49 leonardop Exp $
-inherit gtk-engines2 gnuconfig
+inherit gnuconfig
-IUSE=""
DESCRIPTION="GTK+1 Notif2 Theme Engine"
HOMEPAGE="http://themes.freshmeat.net/projects/notif210/"
SRC_URI="http://download.freshmeat.net/themes/notif210/notif210-1.2.tar.gz"
KEYWORDS="x86 alpha ppc ~amd64 sparc"
LICENSE="GPL-2"
SLOT="1"
+IUSE=""
DEPEND="=x11-libs/gtk+-1.2*"
@@ -24,6 +24,7 @@ src_unpack() {
}
src_install() {
- einstall || die
- dodoc README INSTALL ChangeLog AUTHORS COPYING
+ einstall || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog README TODO
}