summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-03-08 15:06:40 +0000
committerMichał Górny <mgorny@gentoo.org>2015-03-08 15:06:40 +0000
commit1ad6493fd27d761be642f337767ae1bbc8a949d9 (patch)
tree45cc2bc6bfdef11d3c9e08b0aa6a7a0f36373049 /x11-themes/gtk-engines-xfce
parentCleanup. (diff)
downloadgentoo-2-1ad6493fd27d761be642f337767ae1bbc8a949d9.tar.gz
gentoo-2-1ad6493fd27d761be642f337767ae1bbc8a949d9.tar.bz2
gentoo-2-1ad6493fd27d761be642f337767ae1bbc8a949d9.zip
Xfce 4.12 version bump, bug #541962. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/63 by me and damex.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'x11-themes/gtk-engines-xfce')
-rw-r--r--x11-themes/gtk-engines-xfce/ChangeLog10
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r200.ebuild46
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r300.ebuild48
3 files changed, 103 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-xfce/ChangeLog b/x11-themes/gtk-engines-xfce/ChangeLog
index 512cffe7a2b7..2d466a736768 100644
--- a/x11-themes/gtk-engines-xfce/ChangeLog
+++ b/x11-themes/gtk-engines-xfce/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-themes/gtk-engines-xfce
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/ChangeLog,v 1.180 2015/03/03 12:55:37 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/ChangeLog,v 1.181 2015/03/08 15:06:39 mgorny Exp $
+
+*gtk-engines-xfce-3.2.0-r200 (08 Mar 2015)
+*gtk-engines-xfce-3.2.0-r300 (08 Mar 2015)
+
+ 08 Mar 2015; Michał Górny <mgorny@gentoo.org>
+ +gtk-engines-xfce-3.2.0-r200.ebuild, +gtk-engines-xfce-3.2.0-r300.ebuild:
+ Xfce 4.12 version bump, bug #541962. https://github.com/gentoo/gentoo-portage-
+ rsync-mirror/pull/63 by me and damex.
03 Mar 2015; Yixun Lan <dlan@gentoo.org> gtk-engines-xfce-3.0.1-r201.ebuild:
add arm64 support, tested on A53 board
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r200.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r200.ebuild
new file mode 100644
index 000000000000..8b3543044b8f
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r200.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r200.ebuild,v 1.1 2015/03/08 15:06:39 mgorny Exp $
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf multilib-minimal
+
+DESCRIPTION="A port of Xfce engine to GTK+ 2.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ xfconf_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r300.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r300.ebuild
new file mode 100644
index 000000000000..df31f446c1a5
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r300.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.2.0-r300.ebuild,v 1.1 2015/03/08 15:06:39 mgorny Exp $
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf multilib-minimal
+
+DESCRIPTION="A port of Xfce engine to GTK+ 3.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+COMMON_DEPEND=">=dev-libs/glib-2.24[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.2:3[${MULTILIB_USEDEP}]"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r5
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk2
+ --enable-gtk3
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ xfconf_src_configure
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+}