summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2010-10-19 10:08:41 +0000
committerAlex Alexander <wired@gentoo.org>2010-10-19 10:08:41 +0000
commit43f79808d4d3e705955c8d24468b6a753bb49159 (patch)
treedbb5e8e8826b884ee274b0448ff886e90386273e /x11-themes
parentStable on amd64 wrt bug #341415 (diff)
downloadgentoo-2-43f79808d4d3e705955c8d24468b6a753bb49159.tar.gz
gentoo-2-43f79808d4d3e705955c8d24468b6a753bb49159.tar.bz2
gentoo-2-43f79808d4d3e705955c8d24468b6a753bb49159.zip
fixed automagic kwin dep, bug #338628. warn the user instead of dying if use windeco && ! use kde.
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qtcurve-qt4/ChangeLog9
-rw-r--r--x11-themes/qtcurve-qt4/files/qtcurve-qt4_kwin_automagic_fix.patch38
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-1.6.4-r1.ebuild49
3 files changed, 95 insertions, 1 deletions
diff --git a/x11-themes/qtcurve-qt4/ChangeLog b/x11-themes/qtcurve-qt4/ChangeLog
index 9cbd348f5033..6e553b3abb43 100644
--- a/x11-themes/qtcurve-qt4/ChangeLog
+++ b/x11-themes/qtcurve-qt4/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-themes/qtcurve-qt4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.112 2010/10/05 00:15:53 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.113 2010/10/19 10:08:41 wired Exp $
+
+*qtcurve-qt4-1.6.4-r1 (19 Oct 2010)
+
+ 19 Oct 2010; Alex Alexander <wired@gentoo.org>
+ +files/qtcurve-qt4_kwin_automagic_fix.patch, +qtcurve-qt4-1.6.4-r1.ebuild:
+ fixed automagic kwin dep, bug #338628. warn the user instead of dying if
+ use windeco && ! use kde.
*qtcurve-qt4-1.6.4 (05 Oct 2010)
diff --git a/x11-themes/qtcurve-qt4/files/qtcurve-qt4_kwin_automagic_fix.patch b/x11-themes/qtcurve-qt4/files/qtcurve-qt4_kwin_automagic_fix.patch
new file mode 100644
index 000000000000..ab20c5bdfa9d
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/files/qtcurve-qt4_kwin_automagic_fix.patch
@@ -0,0 +1,38 @@
+diff -u -r QtCurve-KDE4-1.6.4-old/CMakeLists.txt QtCurve-KDE4-1.6.4/CMakeLists.txt
+--- QtCurve-KDE4-1.6.4-old/CMakeLists.txt 2010-10-19 12:24:18.725632000 +0300
++++ QtCurve-KDE4-1.6.4/CMakeLists.txt 2010-10-19 12:26:30.469632000 +0300
+@@ -88,14 +88,16 @@
+ add_subdirectory(colors)
+ add_subdirectory(po)
+
+- find_file(KWINGLOBALS_H kwinglobals.h ${KDE4_INCLUDES}) # kwinglobals.h is new for KDE4
++ if (QTC_KWIN)
++ find_file(KWINGLOBALS_H kwinglobals.h ${KDE4_INCLUDES}) # kwinglobals.h is new for KDE4
+
+- if (KWINGLOBALS_H)
+- add_subdirectory(kwin)
+- add_subdirectory(kwinconfig)
+- else (KWINGLOBALS_H)
+- message("** KWin headers not found - KWin decoration will not be built")
+- endif (KWINGLOBALS_H)
++ if (KWINGLOBALS_H)
++ add_subdirectory(kwin)
++ add_subdirectory(kwinconfig)
++ else (KWINGLOBALS_H)
++ message("** KWin headers not found - KWin decoration will not be built")
++ endif (KWINGLOBALS_H)
++ endif (QTC_KWIN)
+ else (NOT QTC_QT_ONLY)
+ set(CMAKE_INSTALL_PREFIX ${OLD_CMAKE_INSTALL_PREFIX})
+ add_definitions(${QT_DEFINITIONS})
+diff -u -r QtCurve-KDE4-1.6.4-old/config.h.cmake QtCurve-KDE4-1.6.4/config.h.cmake
+--- QtCurve-KDE4-1.6.4-old/config.h.cmake 2010-10-19 12:24:18.725632000 +0300
++++ QtCurve-KDE4-1.6.4/config.h.cmake 2010-10-19 12:24:42.264632000 +0300
+@@ -6,6 +6,7 @@
+ #define KDE4PREFIX "@KDE4PREFIX@"
+
+ #cmakedefine QTC_QT_ONLY
++#cmakedefine QTC_KWIN
+ #cmakedefine QTC_OLD_NVIDIA_ARROW_FIX
+ #cmakedefine QTC_STYLE_SUPPORT
+ #cmakedefine QTC_KWIN_MAX_BUTTON_HACK
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-1.6.4-r1.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.6.4-r1.ebuild
new file mode 100644
index 000000000000..4872f23165d7
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-1.6.4-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-1.6.4-r1.ebuild,v 1.1 2010/10/19 10:08:41 wired Exp $
+
+EAPI="2"
+KDE_REQUIRED="optional"
+inherit confutils cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://craigd.wikispaces.com/file/view/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde parentless-dialog-fix windeco"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ x11-libs/qt-svg:4
+ kde? ( >=kde-base/systemsettings-${KDE_MINIMAL}
+ windeco? ( >=kde-base/kwin-${KDE_MINIMAL} ) )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+PATCHES=( "${FILESDIR}/${PN}_kwin_automagic_fix.patch" )
+
+pkg_setup() {
+ if ! use kde && use windeco; then
+ ewarn
+ ewarn "Auto-disabling the windeco USE flag since it requires the kde USE"
+ ewarn "flag. To fix this, please enable the kde USE flag."
+ ewarn
+ fi
+ use kde && kde4-base_pkg_setup
+}
+
+src_configure() {
+ mycmakeargs="$(cmake-utils_use parentless-dialog-fix QTC_ENABLE_PARENTLESS_DIALOG_FIX_SUPPORT)"
+ if use kde; then
+ mycmakeargs="${mycmakeargs} $(use windeco && echo "-DQTC_KWIN=true")"
+ kde4-base_src_configure
+ else
+ mycmakeargs="${mycmakeargs} -DQTC_QT_ONLY=true"
+ cmake-utils_src_configure
+ fi
+}