summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2013-02-07 02:59:03 +0000
committerJason A. Donenfeld <zx2c4@gentoo.org>2013-02-07 02:59:03 +0000
commit88cf7115ea0b9c3b1ada18a32f760d2ecb7fddae (patch)
tree33e28258fdfb2561df6d3b98745cc1a0aa379706 /x11-themes
parentStable for HPPA (bug #455930). (diff)
downloadgentoo-2-88cf7115ea0b9c3b1ada18a32f760d2ecb7fddae.tar.gz
gentoo-2-88cf7115ea0b9c3b1ada18a32f760d2ecb7fddae.tar.bz2
gentoo-2-88cf7115ea0b9c3b1ada18a32f760d2ecb7fddae.zip
oxygen-gtk3 has lived in the kde overlay for a while as a 9999 package. The project is now making regular stable versioned releases, which means it's a good time to add this to our tree.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/oxygen-gtk3/ChangeLog11
-rw-r--r--x11-themes/oxygen-gtk3/metadata.xml9
-rw-r--r--x11-themes/oxygen-gtk3/oxygen-gtk3-1.1.2.ebuild43
3 files changed, 63 insertions, 0 deletions
diff --git a/x11-themes/oxygen-gtk3/ChangeLog b/x11-themes/oxygen-gtk3/ChangeLog
new file mode 100644
index 000000000000..a3b0b8e25e78
--- /dev/null
+++ b/x11-themes/oxygen-gtk3/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-themes/oxygen-gtk3
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk3/ChangeLog,v 1.1 2013/02/07 02:59:03 zx2c4 Exp $
+
+*oxygen-gtk3-1.1.2 (07 Feb 2013)
+
+ 07 Feb 2013; Jason A. Donenfeld <zx2c4@gentoo.org> +metadata.xml,
+ +oxygen-gtk3-1.1.2.ebuild:
+ oxygen-gtk3 has lived in the kde overlay for a while as a 9999 package. The
+ project is now making regular stable versioned releases, which means it's a
+ good time to add this to our tree.
diff --git a/x11-themes/oxygen-gtk3/metadata.xml b/x11-themes/oxygen-gtk3/metadata.xml
new file mode 100644
index 000000000000..b079caebd5a5
--- /dev/null
+++ b/x11-themes/oxygen-gtk3/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+ <maintainer>
+ <email>zx2c4@gentoo.org</email>
+ <name>Jason A. Donenfeld</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-themes/oxygen-gtk3/oxygen-gtk3-1.1.2.ebuild b/x11-themes/oxygen-gtk3/oxygen-gtk3-1.1.2.ebuild
new file mode 100644
index 000000000000..6e9ff9773e4e
--- /dev/null
+++ b/x11-themes/oxygen-gtk3/oxygen-gtk3-1.1.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/oxygen-gtk3/oxygen-gtk3-1.1.2.ebuild,v 1.1 2013/02/07 02:59:03 zx2c4 Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="Official GTK+ 3 port of KDE's Oxygen widget style"
+HOMEPAGE="https://projects.kde.org/projects/playground/artwork/oxygen-gtk"
+SRC_URI="http://download.kde.org/stable/${PN}/${PV}/src/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug doc"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+DOCS=(AUTHORS README)
+
+src_install() {
+ if use doc; then
+ { cd "${S}" && doxygen Doxyfile; } || die "Generating documentation failed"
+ HTML_DOCS=( "${S}/doc/html/" )
+ fi
+
+ cmake-utils_src_install
+
+ cat <<-EOF > 99oxygen-gtk3
+CONFIG_PROTECT="/usr/share/themes/oxygen-gtk/gtk-3.0"
+EOF
+ doenvd 99oxygen-gtk3
+}