summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-02-22 14:10:46 +0000
committerAlex Alexander <wired@gentoo.org>2011-02-22 14:10:46 +0000
commit0e90ee129f5fafdcb79fd828066ac40f5089ccb9 (patch)
tree292574abc507dd4732697e7d9f8b204a5bc98b48 /x11-wm/awesome/files
parentVersion bump (diff)
downloadgentoo-2-0e90ee129f5fafdcb79fd828066ac40f5089ccb9.tar.gz
gentoo-2-0e90ee129f5fafdcb79fd828066ac40f5089ccb9.tar.bz2
gentoo-2-0e90ee129f5fafdcb79fd828066ac40f5089ccb9.zip
fixed compilation with cmake-2.8.4, bug #356009
(Portage version: 2.2.0_alpha24/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/awesome/files')
-rw-r--r--x11-wm/awesome/files/awesome-3.4.4-cmake-2.8.4.patch40
-rw-r--r--x11-wm/awesome/files/awesome-3.4.8-cmake-2.8.4.patch23
2 files changed, 63 insertions, 0 deletions
diff --git a/x11-wm/awesome/files/awesome-3.4.4-cmake-2.8.4.patch b/x11-wm/awesome/files/awesome-3.4.4-cmake-2.8.4.patch
new file mode 100644
index 000000000000..5f2a7f949427
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.4.4-cmake-2.8.4.patch
@@ -0,0 +1,40 @@
+fix compilation with cmake 2.8.4 by backporting some changes from 3.8.9 and applying
+ https://awesome.naquadah.org/bugs/index.php?do=details&task_id=869
+
+https://bugs.gentoo.org/show_bug.cgi?id=356009
+--- awesome-3.4.4-orig/CMakeLists.txt 2011-02-22 15:26:17.380000002 +0200
++++ CMakeLists.txt 2011-02-22 16:03:40.219000002 +0200
+@@ -249,22 +249,24 @@
+ # }}}
+
+ # {{{ Theme icons
+-file(GLOB icon_sources ${SOURCE_DIR}/themes/*/titlebar/*.png)
+-set(ALL_ICONS ${icon_sources})
++file(GLOB icon_sources RELATIVE ${SOURCE_DIR} ${SOURCE_DIR}/themes/*/titlebar/*.png)
++
++foreach(icon ${icon_sources})
++ # Copy all icons to the build dir to simplify the following code.
++ # Source paths are interpreted relative to ${SOURCE_DIR}, target paths
++ # relative to ${BUILD_DIR}.
++ get_filename_component(icon_path ${icon} PATH)
++ get_filename_component(icon_name ${icon} NAME)
++ file(COPY ${icon} DESTINATION ${icon_path})
++ set(ALL_ICONS ${ALL_ICONS} "${icon_path}/${icon_name}")
++endforeach()
+
+ macro(a_icon_convert match replacement input)
+ string(REPLACE ${match} ${replacement} output ${input})
+
+ if(NOT ${input} STREQUAL ${output})
+- if(NOT ${output} MATCHES ${BUILD_DIR})
+- string(REPLACE ${SOURCE_DIR} ${BUILD_DIR} output ${output})
+- endif()
+-
+ set(ALL_ICONS ${ALL_ICONS} ${output})
+
+- get_filename_component(output_path ${output} PATH)
+- file(MAKE_DIRECTORY ${output_path})
+-
+ add_custom_command(
+ COMMAND ${CONVERT_EXECUTABLE} ${input} ${ARGN} ${output}
+ OUTPUT ${output}
diff --git a/x11-wm/awesome/files/awesome-3.4.8-cmake-2.8.4.patch b/x11-wm/awesome/files/awesome-3.4.8-cmake-2.8.4.patch
new file mode 100644
index 000000000000..bfa7ab002c61
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.4.8-cmake-2.8.4.patch
@@ -0,0 +1,23 @@
+fix compilation with cmake 2.8.4
+
+https://awesome.naquadah.org/bugs/index.php?do=details&task_id=869
+https://bugs.gentoo.org/show_bug.cgi?id=356009
+--- awesome-3.4.9/CMakeLists.txt.orig
++++ awesome-3.4.9/CMakeLists.txt
+@@ -274,14 +274,15 @@ endif()
+
+ # {{{ Theme icons
+ file(GLOB icon_sources RELATIVE ${SOURCE_DIR} ${SOURCE_DIR}/themes/*/titlebar/*.png)
+-set(ALL_ICONS ${icon_sources})
+
+ foreach(icon ${icon_sources})
+ # Copy all icons to the build dir to simplify the following code.
+ # Source paths are interpreted relative to ${SOURCE_DIR}, target paths
+ # relative to ${BUILD_DIR}.
+ get_filename_component(icon_path ${icon} PATH)
++ get_filename_component(icon_name ${icon} NAME)
+ file(COPY ${icon} DESTINATION ${icon_path})
++ set(ALL_ICONS ${ALL_ICONS} "${icon_path}/${icon_name}")
+ endforeach()
+
+ macro(a_icon_convert match replacement input)