summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2011-02-18 15:37:05 +0000
committerMichael Weber <xmw@gentoo.org>2011-02-18 15:37:05 +0000
commit36e74537ceb0b5145ca4124ad268579e978a9cad (patch)
treef733b903c2975fab186df74cfe7a2195101a133f /x11-wm/cwm/files
parentVersion bump, dropped sparc and hppa because of qt-webkit dependency (diff)
downloadgentoo-2-36e74537ceb0b5145ca4124ad268579e978a9cad.tar.gz
gentoo-2-36e74537ceb0b5145ca4124ad268579e978a9cad.tar.bz2
gentoo-2-36e74537ceb0b5145ca4124ad268579e978a9cad.zip
Version bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/cwm/files')
-rw-r--r--x11-wm/cwm/files/cwm-20110213-Makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-wm/cwm/files/cwm-20110213-Makefile.patch b/x11-wm/cwm/files/cwm-20110213-Makefile.patch
new file mode 100644
index 000000000000..c47ecd4225e2
--- /dev/null
+++ b/x11-wm/cwm/files/cwm-20110213-Makefile.patch
@@ -0,0 +1,35 @@
+--- cwm-20110213/Makefile.orig
++++ cwm-20110213/Makefile
+@@ -15,16 +15,14 @@
+ kbfunc.o mousefunc.o font.o strlcpy.o strlcat.o y.tab.o \
+ strtonum.o fgetln.o
+
+-X11BASE= /usr
+-
+-CPPFLAGS+= -I${X11BASE}/include -I${X11BASE}/include/freetype2 -I.
++CPPFLAGS+= $(shell pkg-config --cflags-only-I xft)
+
+-CFLAGS+= -Wall -O2 -g
++CFLAGS+=
+
+ LDADD+= -L${X11BASE}/lib -lXft -lXrender -lX11 ${LIBXCB} -lXau -lXdmcp \
+ -lfontconfig -lexpat -lfreetype -lz -lXinerama -lXrandr -lXext
+
+-MANDIR= ${X11BASE}/man/cat
++MANDIR= /usr/share/man
+ MAN= cwm.1 cwmrc.5
+
+ CLEANFILES= cwm.cat1 cwmrc.cat5
+@@ -46,9 +45,9 @@
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) $<
+
+ install: ${PROG}
+- install -m 755 cwm /usr/local/bin/
+- install -m 644 cwm.1 /usr/local/man/man1
+- install -m 644 cwmrc.5 /usr/local/man/man5
++ install -D -m 755 cwm $(DESTDIR)$(BINDIR)/cwm
++ install -D -m 644 cwm.1 $(DESTDIR)$(MANDIR)/man1/cwm.1
++ install -D -m 644 cwmrc.5 $(DESTDIR)$(MANDIR)/man5/cwmrc.5
+
+ #.include <bsd.prog.mk>
+ #.include <bsd.xorg.mk>