summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-11-12 09:07:21 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-11-12 09:07:21 +0000
commit3e8d43c1e19b51d2aee14527d472b4fed8cbe4fe (patch)
tree07b424e83550b251881e977e9036e7ee37b7dd47 /x11-wm/fvwm
parentSRC_URI fix. (diff)
downloadgentoo-2-3e8d43c1e19b51d2aee14527d472b4fed8cbe4fe.tar.gz
gentoo-2-3e8d43c1e19b51d2aee14527d472b4fed8cbe4fe.tar.bz2
gentoo-2-3e8d43c1e19b51d2aee14527d472b4fed8cbe4fe.zip
perllib fix.
Diffstat (limited to 'x11-wm/fvwm')
-rw-r--r--x11-wm/fvwm/Manifest4
-rw-r--r--x11-wm/fvwm/files/fvwm-2.5.8-perllib-disconnect.diff42
-rw-r--r--x11-wm/fvwm/fvwm-2.5.8.ebuild9
3 files changed, 44 insertions, 11 deletions
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index fd6934494af2..e04514e0184d 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -1,5 +1,5 @@
MD5 e79bd2fa2e46e650aabaa16754e25583 fvwm-2.5.7-r5.ebuild 8757
-MD5 f8215c0c3acb295b45d8c44763e8d5f4 fvwm-2.5.8.ebuild 9081
+MD5 4cb963d46899b4e7b468135b2b8688d4 fvwm-2.5.8.ebuild 9113
MD5 b893f78193652b275ce5d276ac38af29 fvwm-2.4.17.ebuild 3961
MD5 8fa93269e89c39d61e797e46a91b2872 fvwm-2.5.7-r3.ebuild 8726
MD5 a3663b67114af0af40f4bd9fb2cfe69c ChangeLog 9092
@@ -8,7 +8,7 @@ MD5 e2ceb5d855c5406a09d82442196efad8 files/README.transluceny.gz 5788
MD5 e5701841190ad529d5577c8da69d5006 files/fvwmtabs-insecure-tmp-handling.diff 2350
MD5 b2af3c1c8fe4f142e2b8debbb5c59a94 files/digest-fvwm-2.4.17 65
MD5 38cb0131791d07053b5d90bf21d1993f files/fvwm-translucent-menus.diff.gz 3582
-MD5 f43ef0d2ee76f403eea9ead9c5e5a297 files/fvwm-2.5.8-perllib-disconnect.diff 475
+MD5 977c11b7ca7c17cff7a14d1d4a0136f4 files/fvwm-2.5.8-perllib-disconnect.diff 1179
MD5 2bdb17132f9d7f352002a1fbace7fca1 files/acinclude.m4 61423
MD5 df03a10a40a620ce8f1fab75f9758884 files/disable-debug-statements.diff 419
MD5 719ab11e70adb34bdf0a3fa0541b3ca6 files/digest-fvwm-2.5.8 127
diff --git a/x11-wm/fvwm/files/fvwm-2.5.8-perllib-disconnect.diff b/x11-wm/fvwm/files/fvwm-2.5.8-perllib-disconnect.diff
index 729c9896cf02..5fb19176c00e 100644
--- a/x11-wm/fvwm/files/fvwm-2.5.8-perllib-disconnect.diff
+++ b/x11-wm/fvwm/files/fvwm-2.5.8-perllib-disconnect.diff
@@ -1,11 +1,43 @@
-diff -ruN fvwm-2.5.8.orig/perllib/FVWM/Module/Tk.pm fvwm-2.5.8/perllib/FVWM/Module/Tk.pm
---- fvwm-2.5.8.orig/perllib/FVWM/Module/Tk.pm 2003-10-23 13:07:10.000000000 +0100
-+++ fvwm-2.5.8/perllib/FVWM/Module/Tk.pm 2003-11-11 21:37:03.000000000 +0000
-@@ -51,6 +51,7 @@
+--- perllib/FVWM/Module/Tk.pm 2003-11-12 08:55:58.000000000 +0000
++++ perllib/FVWM/Module/Tk.pm 2003-11-12 04:13:25.000000000 +0000
+@@ -51,6 +51,14 @@
$top->fileevent($self->{istream},
readable => sub {
unless ($self->processPacket($self->readPacket)) {
-+ $self->disconnect;
++ if ($self->{disconnected}) {
++ # Seems like something does not want to exit - force it.
++ # For example, a new Tk window is launched on ON_EXIT.
++ $top->destroy if defined $top && defined $top->{Configure};
++ $self->debug("Forced to exit to escape eventLoop, fix the module", 0);
++ exit 1;
++ }
++ $self->eventLoopFinished(@params);
$top->destroy;
} else {
$self->eventLoopPrepared(@params);
+@@ -58,7 +66,6 @@
+ }
+ );
+ MainLoop;
+- $self->eventLoopFinished(@params);
+ }
+
+ sub showError ($$;$) {
+@@ -73,7 +80,7 @@
+ -bitmap => 'error',
+ -default_button => 'Close',
+ -text => $error,
+- -buttons => ['Close', 'Close All Errors', 'Exit Module']
++ -buttons => ['Close', 'Close All Errors', 'Exit Module'],
+ );
+ my $btn = $dialog->Show;
+
+@@ -90,7 +97,7 @@
+ -icon => 'info',
+ -type => 'ok',
+ -title => $title,
+- -message => $msg
++ -message => $msg,
+ );
+ }
+
diff --git a/x11-wm/fvwm/fvwm-2.5.8.ebuild b/x11-wm/fvwm/fvwm-2.5.8.ebuild
index e49ac7899192..57d9cfd7009c 100644
--- a/x11-wm/fvwm/fvwm-2.5.8.ebuild
+++ b/x11-wm/fvwm/fvwm-2.5.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.8.ebuild,v 1.11 2003/11/11 22:10:43 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.8.ebuild,v 1.12 2003/11/12 09:07:16 taviso Exp $
inherit eutils flag-o-matic
@@ -67,9 +67,10 @@ src_unpack() {
# moving it into ~/.fvwmtabs.state will do for now.
cd ${WORKDIR}; epatch ${FILESDIR}/fvwmtabs-insecure-tmp-handling.diff
- # this patch was sent to the fvwm-workers mailing list in
- # <20031111234845.A12314@deepblue.milkyway.com.au>, perllib applications
- # were getting destroyed before the ON_EXIT handler could be invoked.
+ # this patch from cvs, regarding a message sent to the fvwm-workers
+ # mailing list in <20031111234845.A12314@deepblue.milkyway.com.au>,
+ # perllib applications were getting destroyed before the ON_EXIT
+ # handler could be invoked.
cd ${S}; epatch ${FILESDIR}/fvwm-2.5.8-perllib-disconnect.diff
# build fails on alpha with certain options without this.