summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-02-11 04:43:00 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-02-11 04:43:00 +0000
commit7ccfd1f8effb535f4e8ea932515a2bb6c7a66991 (patch)
treefc59ee979d759d6eac9f77b76de5cda6ceb9c5a4 /x11-wm/icewm
parentUpdate to pcmcia-cs and a housecleaning. We now configure pcmcia-cs for (diff)
downloadgentoo-2-7ccfd1f8effb535f4e8ea932515a2bb6c7a66991.tar.gz
gentoo-2-7ccfd1f8effb535f4e8ea932515a2bb6c7a66991.tar.bz2
gentoo-2-7ccfd1f8effb535f4e8ea932515a2bb6c7a66991.zip
adding missing ebuilds from previous commits (oops!)
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/icewm-1.0.9.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-wm/icewm/icewm-1.0.9.2-r1.ebuild b/x11-wm/icewm/icewm-1.0.9.2-r1.ebuild
new file mode 100644
index 000000000000..0ecffb2158c9
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.0.9.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.0.9.2-r1.ebuild,v 1.1 2002/02/11 04:43:00 drobbins Exp $
+
+NV=1.0.9-2
+S=${WORKDIR}/icewm-1.0.9
+DESCRIPTION="Ice Window Manager"
+SRC_URI="prdownloads.sourceforge.net/${PN}/${PN}-${NV}.tar.gz"
+HOMEPAGE="www.icewm.org"
+
+DEPEND="virtual/x11 media-libs/imlib"
+
+src_compile(){
+ ./configure --with-imlib --host=${CHOST} --prefix=/usr --sysconfdir=/etc || die
+ emake || die
+}
+src_install(){
+ make prefix=${D}/usr DOCDIR=${S}/dummy sysconfdir=${D}/etc install || die
+ dodoc BUGS CHANGES COPYING FAQ PLATFORMS README TODO VERSION
+ docinto html
+ dodoc doc/*.html
+ docinto sgml
+ dodoc doc/*.sgml
+}
+
+