summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-01-09 20:21:52 +0000
committerCédric Krier <cedk@gentoo.org>2007-01-09 20:21:52 +0000
commit0f64ee5645901edd66eb895d60484caaab53ec76 (patch)
treea547d2595ba3fb3e576289aeda2fc6e6ad6ee7d8 /x11-wm
parentDon't mask the firebird USE, as it already is unmasked on newer selinux profi... (diff)
downloadgentoo-2-0f64ee5645901edd66eb895d60484caaab53ec76.tar.gz
gentoo-2-0f64ee5645901edd66eb895d60484caaab53ec76.tar.bz2
gentoo-2-0f64ee5645901edd66eb895d60484caaab53ec76.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/ChangeLog8
-rw-r--r--x11-wm/dwm/dwm-2.9.ebuild93
-rw-r--r--x11-wm/dwm/files/digest-dwm-2.93
-rw-r--r--x11-wm/dwm/files/dwm.desktop8
4 files changed, 111 insertions, 1 deletions
diff --git a/x11-wm/dwm/ChangeLog b/x11-wm/dwm/ChangeLog
index 3c0eec531178..d57bac5906db 100644
--- a/x11-wm/dwm/ChangeLog
+++ b/x11-wm/dwm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/dwm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.2 2007/01/07 14:51:25 cedk Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/ChangeLog,v 1.3 2007/01/09 20:21:52 cedk Exp $
+
+*dwm-2.9 (09 Jan 2007)
+
+ 09 Jan 2007; Cedric Krier <cedk@gentoo.org> +files/dwm.desktop,
+ +dwm-2.9.ebuild:
+ Version bump
07 Jan 2007; Cedric Krier <cedk@gentoo.org> dwm-2.8.ebuild:
Improve pkg_preinst
diff --git a/x11-wm/dwm/dwm-2.9.ebuild b/x11-wm/dwm/dwm-2.9.ebuild
new file mode 100644
index 000000000000..3a7cb70d768a
--- /dev/null
+++ b/x11-wm/dwm/dwm-2.9.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/dwm/dwm-2.9.ebuild,v 1.1 2007/01/09 20:21:52 cedk Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://suckless.org/view/dynamic+window+manager"
+SRC_URI="http://suckless.org/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="savedconfig"
+
+DEPEND="x11-libs/libX11"
+RDEPEND=${DEPEND}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s/.*strip.*//" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e "s/CFLAGS = -Os/CFLAGS +=/" \
+ -e "s/LDFLAGS =/LDFLAGS +=/" \
+ config.mk || die "sed failed"
+
+ if use savedconfig; then
+ local conf root
+ [[ -r config.h ]] && rm config.h
+ for conf in ${PF} ${P} ${PN}; do
+ for root in "${PORTAGE_CONFIGROOT}" "${ROOT}" /; do
+ configfile=${root}etc/portage/savedconfig/${conf}.config.h
+ if [[ -r ${configfile} ]]; then
+ elog "Found your ${configfile} and using it."
+ cp ${configfile} "${S}"/config.h
+ return 0
+ fi
+ done
+ done
+ ewarn "Could not locate user configfile, so we will save a default one."
+ fi
+}
+
+src_compile() {
+ local msg
+ use savedconfig && msg=", please check the configfile"
+ emake CC=$(tc-getCC) || die "emake failed${msg}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install || die "emake install failed"
+
+ insinto /usr/share/${PN}
+ newins config.h ${PF}.config.h
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+}
+
+pkg_preinst() {
+ if use savedconfig; then
+ mv "${D}"/usr/share/${PN}/${PF}.config.h "${T}"/ || die
+ fi
+}
+
+pkg_postinst() {
+ if use savedconfig; then
+ local config_dir="${PORTAGE_CONFIGROOT:-${ROOT}}/etc/portage/savedconfig"
+ elog "Saving this build config to ${config_dir}/${PF}.config.h"
+ einfo "Read this ebuild for more info on how to take advantage of this option."
+ mkdir -p "${config_dir}"
+ cp "${T}"/${PF}.config.h "${config_dir}"/${PF}.config.h
+ fi
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+}
diff --git a/x11-wm/dwm/files/digest-dwm-2.9 b/x11-wm/dwm/files/digest-dwm-2.9
new file mode 100644
index 000000000000..7e8f5f6b4357
--- /dev/null
+++ b/x11-wm/dwm/files/digest-dwm-2.9
@@ -0,0 +1,3 @@
+MD5 5f8a5c9afe20b866cdcb5b84a2c51bbe dwm-2.9.tar.gz 17956
+RMD160 ca32f2ec08bc6c5cb9cd61b1c868a9b159454a6f dwm-2.9.tar.gz 17956
+SHA256 6af95423f8f88fc10307f2ffe1c08b37e2d2c3f64b7c389b8a79b06136266dd3 dwm-2.9.tar.gz 17956
diff --git a/x11-wm/dwm/files/dwm.desktop b/x11-wm/dwm/files/dwm.desktop
new file mode 100644
index 000000000000..bc943a1fed2a
--- /dev/null
+++ b/x11-wm/dwm/files/dwm.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=dwm
+Comment=dynamic window manager
+Exec=/etc/X11/Sessions/dwm
+TryExec=dwm
+Icon=
+Type=Xsession