summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2003-07-31 22:25:39 +0000
committerTavis Ormandy <taviso@gentoo.org>2003-07-31 22:25:39 +0000
commit8e381d7c09270d293b99e62ecdf46ab2b949b829 (patch)
tree7c066cf51df888bae68b64ae868621442e83b18f /x11-wm
parentback-porting new fix to fvwm-2.4.16-r1 (diff)
downloadgentoo-2-8e381d7c09270d293b99e62ecdf46ab2b949b829.tar.gz
gentoo-2-8e381d7c09270d293b99e62ecdf46ab2b949b829.tar.bz2
gentoo-2-8e381d7c09270d293b99e62ecdf46ab2b949b829.zip
back-porting new fix to fvwm-2.4.16-r1
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fvwm/Manifest2
-rw-r--r--x11-wm/fvwm/files/digest-fvwm-2.4.16-r11
-rw-r--r--x11-wm/fvwm/fvwm-2.4.16-r1.ebuild (renamed from x11-wm/fvwm/fvwm-2.5.7.ebuild)85
3 files changed, 12 insertions, 76 deletions
diff --git a/x11-wm/fvwm/Manifest b/x11-wm/fvwm/Manifest
index a1fb406bd271..49d3afe1d3ef 100644
--- a/x11-wm/fvwm/Manifest
+++ b/x11-wm/fvwm/Manifest
@@ -1,5 +1,5 @@
MD5 616d23339ff772ad286c142eee37efc8 fvwm-2.4.15.ebuild 1167
-MD5 afeb5b473a944f4b2ce6e763f3fa3a1d fvwm-2.4.16-r1.ebuild 4361
+MD5 a1b5e28dc1a3a1930c69abae86ac760d fvwm-2.4.16-r1.ebuild 4022
MD5 640cc8cf1c7b29a974fed717d4460794 fvwm-2.4.14.ebuild 1102
MD5 68bf17ef6eb652db56613550d3ec89eb fvwm-2.5.7.ebuild 5977
MD5 9b68cbbbdaba95b23665ea98c695e57d fvwm-2.4.16.ebuild 1334
diff --git a/x11-wm/fvwm/files/digest-fvwm-2.4.16-r1 b/x11-wm/fvwm/files/digest-fvwm-2.4.16-r1
new file mode 100644
index 000000000000..39c73fc10cd2
--- /dev/null
+++ b/x11-wm/fvwm/files/digest-fvwm-2.4.16-r1
@@ -0,0 +1 @@
+MD5 f63ea14b61a1aeb670f8d9b8ff20a29f fvwm-2.4.16.tar.bz2 1375565
diff --git a/x11-wm/fvwm/fvwm-2.5.7.ebuild b/x11-wm/fvwm/fvwm-2.4.16-r1.ebuild
index c760d98e98f5..c29c4d6df071 100644
--- a/x11-wm/fvwm/fvwm-2.5.7.ebuild
+++ b/x11-wm/fvwm/fvwm-2.4.16-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.5.7.ebuild,v 1.15 2003/07/31 16:09:09 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/fvwm/fvwm-2.4.16-r1.ebuild,v 1.1 2003/07/31 22:25:31 taviso Exp $
inherit gnuconfig
-IUSE="readline ncurses gtk stroke gnome rplay xinerama cjk perl nls png bidi doc imlib"
+IUSE="readline ncurses gtk stroke gnome rplay xinerama cjk imlib"
S=${WORKDIR}/${P}
DESCRIPTION="an extremely powerful ICCCM-compliant multiple virtual desktop window manager"
@@ -23,35 +23,22 @@ RDEPEND="readline? ( >=sys-libs/readline-4.1
>=media-libs/imlib-1.9.14-r1 ) )
gnome? ( >=gnome-base/gnome-libs-1.4.1.2-r1 )
rplay? ( >=media-sound/rplay-3.3.2 )
- perl? ( >=dev-lang/perl-5.6.1-r10 )
- bidi? ( >=dev-libs/fribidi-0.10.4 )
- png? ( >=media-libs/libpng-1.0.12-r2 )
stroke? ( >=dev-libs/libstroke-0.4 )
- doc? ( >=media-libs/netpbm-9.12-r4 )
- >=media-libs/fontconfig-2.1-r1
- >=dev-libs/expat-1.95.6-r1
- virtual/x11
- virtual/xft"
+ >=dev-lang/perl-5.8.0
+ virtual/x11"
DEPEND="${RDEPEND}
- >=sys-apps/sed-4
- sys-devel/automake
- sys-devel/autoconf
- dev-util/pkgconfig"
+ >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
-
use alpha && gnuconfig_update
# CFLAGS containing comma will break this, so change it for !
sed -i 's#\x27s,xCFLAGSx,$(CFLAGS),\x27#\x27s!xCFLAGSx!$(CFLAGS)!\x27#' ${S}/utils/Makefile.am
-
- # Xft detection is totally b0rked if using pkg-config, this update from cvs.
- cp ${FILESDIR}/acinclude.m4 ${S}/acinclude.m4
}
src_compile() {
- local myconf="--libexecdir=/usr/lib --enable-xft"
+ local myconf="--libexecdir=/usr/lib"
# use readline in FvwmConsole.
if ! use readline; then
@@ -90,13 +77,6 @@ src_compile() {
myconf="${myconf} --without-rplay-library"
fi
- # Install perl bindings for FvwmPerl.
- if use perl; then
- myconf="${myconf} --enable-perllib"
- else
- myconf="${myconf} --disable-perllib"
- fi
-
# xinerama support for those who have multi-headed machines.
if use xinerama; then
myconf="${myconf} --enable-xinerama"
@@ -111,45 +91,13 @@ src_compile() {
myconf="${myconf} --disable-multibyte"
fi
- # bidirectional writing support, eg hebrew
- if use bidi; then
- myconf="${myconf} --enable-bidi"
- else
- myconf="${myconf} --disable-bidi"
- fi
-
- # png image support (very nice in fvwm)
- if ! use png; then
- myconf="${myconf} --without-png-library"
- fi
-
- # native language support
- if use nls; then
- myconf="${myconf} --enable-nls"
- else
- myconf="${myconf} --disable-nls"
- fi
-
# support for mouse gestures using libstroke (very very cool)
if ! use stroke; then
myconf="${myconf} --without-stroke-library"
fi
- # Xft detection is broken in this release, the fix is in cvs
- # which ive installed here, rerun automake to sort the problem.
- einfo "Fixing Xft detection, please wait..."
- ( einfo " Running aclocal..."
- aclocal
- einfo " Running autoheader..."
- autoheader
- einfo " Running automake..."
- automake --add-missing
- einfo " Running autoreconf..."
- autoreconf ) 2>/dev/null
- einfo "Fixed."
-
# must specify PKG_CONFIG or Xft detection bombs.
- econf ${myconf} PKG_CONFIG=/usr/bin/pkg-config || die
+ econf ${myconf} || die
emake || die
}
@@ -163,30 +111,19 @@ src_install() {
doexe fvwm2
dodoc AUTHORS ChangeLog COPYING README NEWS docs/ANNOUNCE docs/BUGS \
- docs/COMMANDS docs/DEVELOPERS docs/FAQ docs/error_codes docs/TODO \
- docs/fvwm.lsm
-
- # optional example scripts (generate dynamic menus - really awesome, try
- # this out) :)
- use doc && dodoc utils/fvwm_make_directory_menu.sh \
- utils/fvwm_make_browse_menu.sh utils/quantize_pixmaps
+ docs/DEVELOPERS docs/FAQ docs/error_codes docs/color_combos docs/TODO \
+ docs/fvwm.lsm
}
pkg_postinst() {
- local i
ewarn
- ewarn "The Gentoo FVWM ebuild has been altered since the 2.4.x Branch."
ewarn "The following features that you did not request are now"
- ewarn "controlled via USE flags, and not enabled automatically:"
+ ewarn "controlled via USE flags:"
use readline || ewarn " Readline support in FvwmConsole [readline]"
use ncurses || ewarn " Ncurses support in FvwmConsole [ncurses]"
use stroke || ewarn " Mouse Gestures [stroke]"
use xinerama || ewarn " Xinerama Support [xinerama]"
use cjk || ewarn " Multibyte Character Support [cjk]"
- use perl || ewarn " FVWM Perl bindings [perl]"
- use nls || ewarn " Native Language Support [nls]"
- use png || ewarn " PNG Support [png]"
- use bidi || ewarn " Bidirectional Language Support [bidi]"
use rplay || ewarn " RPlay Support in FvwmEvent [rplay]"
use gtk || ewarn " FvwmGTK (gtk+ support) [gtk]"
use imlib || ewarn " FvwmGTK (GDK image support) [imlib]"
@@ -196,6 +133,4 @@ pkg_postinst() {
ewarn "available:"
ewarn " $ emerge -pv fvwm"
ewarn
-
- for ((i=0;i<5;i++)); do echo -ne '\a'; sleep 1; done
}