summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2007-12-05 10:28:14 +0000
committerChristoph Mende <angelos@gentoo.org>2007-12-05 10:28:14 +0000
commit77cf546db8e3355dc70e9f33195e6c413777dcc6 (patch)
tree77770e70c1fb1fd24df287cd72c7c485c1e3d57a /xfce-base/libxfce4util
parent-m Added dotproject-2.1.1 to the tree. Includes security fixes: Removed (diff)
downloadgentoo-2-77cf546db8e3355dc70e9f33195e6c413777dcc6.tar.gz
gentoo-2-77cf546db8e3355dc70e9f33195e6c413777dcc6.tar.bz2
gentoo-2-77cf546db8e3355dc70e9f33195e6c413777dcc6.zip
Fixed a possible buffer overflow, bug 201289
(Portage version: 2.1.3.19)
Diffstat (limited to 'xfce-base/libxfce4util')
-rw-r--r--xfce-base/libxfce4util/ChangeLog8
-rw-r--r--xfce-base/libxfce4util/files/digest-libxfce4util-4.4.1-r13
-rw-r--r--xfce-base/libxfce4util/files/libxfce4util-4.4.1-overflow.patch19
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.4.1-r1.ebuild45
4 files changed, 74 insertions, 1 deletions
diff --git a/xfce-base/libxfce4util/ChangeLog b/xfce-base/libxfce4util/ChangeLog
index 4dd339e044bb..149e58f5be28 100644
--- a/xfce-base/libxfce4util/ChangeLog
+++ b/xfce-base/libxfce4util/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/libxfce4util
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4util/ChangeLog,v 1.96 2007/11/18 06:23:13 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4util/ChangeLog,v 1.97 2007/12/05 10:28:14 angelos Exp $
+
+*libxfce4util-4.4.1-r1 (04 Dec 2007)
+
+ 04 Dec 2007; Christoph Mende <angelos@gentoo.org>
+ +files/libxfce4util-4.4.1-overflow.patch, +libxfce4util-4.4.1-r1.ebuild:
+ Fixed a possible buffer overflow, bug 201289
*libxfce4util-4.4.2 (18 Nov 2007)
diff --git a/xfce-base/libxfce4util/files/digest-libxfce4util-4.4.1-r1 b/xfce-base/libxfce4util/files/digest-libxfce4util-4.4.1-r1
new file mode 100644
index 000000000000..7e79f98305b1
--- /dev/null
+++ b/xfce-base/libxfce4util/files/digest-libxfce4util-4.4.1-r1
@@ -0,0 +1,3 @@
+MD5 0e4011c57ca2b4491e715455a40c30bc libxfce4util-4.4.1.tar.bz2 372848
+RMD160 fa05dcf9e48d96dcae8ea1368647064e10a41a87 libxfce4util-4.4.1.tar.bz2 372848
+SHA256 2195969e71ba7408d936e7663e34c0540b10cb7c7353dbc34dbbb1df9e418182 libxfce4util-4.4.1.tar.bz2 372848
diff --git a/xfce-base/libxfce4util/files/libxfce4util-4.4.1-overflow.patch b/xfce-base/libxfce4util/files/libxfce4util-4.4.1-overflow.patch
new file mode 100644
index 000000000000..1cbf51642bea
--- /dev/null
+++ b/xfce-base/libxfce4util/files/libxfce4util-4.4.1-overflow.patch
@@ -0,0 +1,19 @@
+Index: libxfce4util/xfce-fileutils.c
+===================================================================
+--- libxfce4util/xfce-fileutils.c (revision 26180)
++++ libxfce4util/xfce-fileutils.c (working copy)
+@@ -90,12 +90,11 @@
+ last = 1;
+ else if (p[0] != '/')
+ continue;
++ else if (p[1] == '\0')
++ last = 1;
+
+ *p = '\0';
+
+- if (p[1] == '\0')
+- last = 1;
+-
+ if (first)
+ {
+ /*
diff --git a/xfce-base/libxfce4util/libxfce4util-4.4.1-r1.ebuild b/xfce-base/libxfce4util/libxfce4util-4.4.1-r1.ebuild
new file mode 100644
index 000000000000..7094632e35e7
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.4.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4util/libxfce4util-4.4.1-r1.ebuild,v 1.1 2007/12/05 10:28:14 angelos Exp $
+
+inherit eutils xfce44
+
+XFCE_VERSION="4.4.1"
+xfce44
+
+DESCRIPTION="Basic utilities library"
+HOMEPAGE="http://www.xfce.org/projects/libraries"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc"
+
+RDEPEND=">=dev-libs/glib-2.6"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( dev-util/gtk-doc )
+ !xfce-extra/xfce4-panelmenu
+ !xfce-extra/xfce4-showdesktop
+ !xfce-extra/xfce4-systray
+ !xfce-extra/xfce4-taskbar
+ !xfce-extra/xfce4-toys
+ !xfce-extra/xfce4-windowlist
+ !xfce-extra/xfce4-trigger-launcher
+ !xfce-extra/xfce4-websearch
+ !xfce-extra/xfce4-modemlights
+ !xfce-extra/xfce4-minicmd
+ !xfce-extra/xfce4-megahertz
+ !xfce-extra/xfce4-iconbox
+ !xfce-base/xffm
+ !xfce-extra/xfcalendar
+ !xfce-extra/xfce4-bglist-editor
+ !<xfce-extra/xfce4-genmon-3
+ !<xfce-extra/xfce4-diskperf-2"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-overflow.patch
+}
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS TODO"
+
+xfce44_core_package