summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2009-10-19 21:13:27 +0000
committerSebastian Pipping <sping@gentoo.org>2009-10-19 21:13:27 +0000
commit347d114cd0658fc9f540254b33ff3db193ab81dd (patch)
tree97ff107a57e328b965548ef0224b7c3b07b2f9e8 /xfce-base/xfce4-session
parentSwitch virtualx.eclass to use the "test" USE flag by default (bug 157998) (diff)
downloadgentoo-2-347d114cd0658fc9f540254b33ff3db193ab81dd.tar.gz
gentoo-2-347d114cd0658fc9f540254b33ff3db193ab81dd.tar.bz2
gentoo-2-347d114cd0658fc9f540254b33ff3db193ab81dd.zip
Fix xfce4-tips
(Portage version: 2.2_rc41/cvs/Linux i686)
Diffstat (limited to 'xfce-base/xfce4-session')
-rw-r--r--xfce-base/xfce4-session/ChangeLog8
-rw-r--r--xfce-base/xfce4-session/metadata.xml1
-rw-r--r--xfce-base/xfce4-session/xfce4-session-4.6.1-r1.ebuild61
3 files changed, 69 insertions, 1 deletions
diff --git a/xfce-base/xfce4-session/ChangeLog b/xfce-base/xfce4-session/ChangeLog
index ff1be48caff2..2cd1de07e152 100644
--- a/xfce-base/xfce4-session/ChangeLog
+++ b/xfce-base/xfce4-session/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce4-session
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/ChangeLog,v 1.99 2009/10/06 21:18:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/ChangeLog,v 1.100 2009/10/19 21:13:27 sping Exp $
+
+*xfce4-session-4.6.1-r1 (19 Oct 2009)
+
+ 19 Oct 2009; Sebastian Pipping <sping@gentoo.org>
+ +xfce4-session-4.6.1-r1.ebuild, metadata.xml:
+ Fix xfce4-tips: it relies on fortune to display tips, not just fortunes
06 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
xfce4-session-4.6.1.ebuild:
diff --git a/xfce-base/xfce4-session/metadata.xml b/xfce-base/xfce4-session/metadata.xml
index 83abf5f159ed..9a21c71866d3 100644
--- a/xfce-base/xfce4-session/metadata.xml
+++ b/xfce-base/xfce4-session/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>xfce</herd>
<use>
+ <flag name="fortune">Install tips and tricks app (xfce4-tips), adds dependency on games-misc/fortune-mod</flag>
<flag name="gnome-keyring">Support for storing your password.</flag>
</use>
</pkgmetadata>
diff --git a/xfce-base/xfce4-session/xfce4-session-4.6.1-r1.ebuild b/xfce-base/xfce4-session/xfce4-session-4.6.1-r1.ebuild
new file mode 100644
index 000000000000..871561c1928f
--- /dev/null
+++ b/xfce-base/xfce4-session/xfce4-session-4.6.1-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-session/xfce4-session-4.6.1-r1.ebuild,v 1.1 2009/10/19 21:13:27 sping Exp $
+
+EAPI=2
+inherit flag-o-matic xfconf
+
+DESCRIPTION="Session manager for Xfce4"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-session/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug +fortune gnome gnome-keyring profile"
+
+RDEPEND="gnome-base/libglade
+ >=dev-libs/dbus-glib-0.73
+ x11-libs/libX11
+ x11-libs/libSM
+ >=x11-libs/libwnck-2.12
+ x11-apps/iceauth
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
+ >=xfce-base/xfce-utils-4.6
+ gnome? ( gnome-base/gconf )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ fortune? ( games-misc/fortune-mod )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ --disable-static
+ $(use_enable gnome)
+ $(use_enable gnome-keyring libgnome-keyring)
+ $(use_enable debug)
+ $(use_enable profile profiling)
+ $(use_enable profile gcov)"
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+}
+
+src_configure() {
+ use profile && filter-flags -fomit-frame-pointer
+ xfconf_src_configure
+}
+
+src_install() {
+ xfconf_src_install
+
+ if ! use fortune ; then
+ # Wipe away unusable xfce4-tips
+ rm -Rf "${D}"/usr/share/xfce4/tips
+ rm -f "${D}"/usr/bin/xfce4-tips \
+ "${D}"/usr/lib/debug/usr/bin/xfce4-tips.debug \
+ "${D}"/etc/xdg/autostart/xfce4-tips-autostart.desktop
+ rmdir -p "${D}"/etc/xdg/autostart
+ fi
+}