summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-10-05 21:22:30 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-10-05 21:22:30 +0000
commit16ba939fff5b4c4d4892147551083edc9d6a3f4a (patch)
treec999e0f0013faf4d935ba53e3ac845d41f7f2674 /xfce-base/xfconf/xfconf-4.6.1.ebuild
parentPort Gentoo Prefix ebuild to gentoo-x86 (diff)
downloadgentoo-2-16ba939fff5b4c4d4892147551083edc9d6a3f4a.tar.gz
gentoo-2-16ba939fff5b4c4d4892147551083edc9d6a3f4a.tar.bz2
gentoo-2-16ba939fff5b4c4d4892147551083edc9d6a3f4a.zip
Port Gentoo Prefix ebuild to gentoo-x86
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfconf/xfconf-4.6.1.ebuild')
-rw-r--r--xfce-base/xfconf/xfconf-4.6.1.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/xfce-base/xfconf/xfconf-4.6.1.ebuild b/xfce-base/xfconf/xfconf-4.6.1.ebuild
index b33dd54afc57..57fb98c63e87 100644
--- a/xfce-base/xfconf/xfconf-4.6.1.ebuild
+++ b/xfce-base/xfconf/xfconf-4.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.6.1.ebuild,v 1.12 2009/08/02 10:16:31 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfconf/xfconf-4.6.1.ebuild,v 1.13 2009/10/05 21:22:30 darkside Exp $
EAPI=2
inherit flag-o-matic xfconf
@@ -10,7 +10,7 @@ HOMEPAGE="http://www.xfce.org"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug -perl profile"
RDEPEND=">=dev-libs/dbus-glib-0.72
@@ -48,7 +48,9 @@ src_install() {
xfconf_src_install
if use perl; then
- find "${D}" -type f -name perllocal.pod -delete
- find "${D}" -depth -mindepth 1 -type d -empty -delete
+ # Prefix compat. In Gentoo Linux, defaults to ${D}
+ [[ -z ${ED} ]] && local ED=${D}
+ find "${ED}" -type f -name perllocal.pod -delete
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete
fi
}