summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2007-02-15 01:36:53 +0000
committerJoshua Nichols <nichoj@gentoo.org>2007-02-15 01:36:53 +0000
commit1fb87781a657eb71c0a77d546b19097164ea1823 (patch)
tree809a9848100b4de39f9ea4647123e28681cbab48 /xfce-base
parentVersion Bump. Closes bug #166840. Remove older version. (diff)
downloadgentoo-2-1fb87781a657eb71c0a77d546b19097164ea1823.tar.gz
gentoo-2-1fb87781a657eb71c0a77d546b19097164ea1823.tar.bz2
gentoo-2-1fb87781a657eb71c0a77d546b19097164ea1823.zip
Added linguas to IUSE for controlling installation of localized configuration files.
(Portage version: 2.1.2-r9)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfdesktop/ChangeLog6
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.4.0-r3.ebuild27
2 files changed, 29 insertions, 4 deletions
diff --git a/xfce-base/xfdesktop/ChangeLog b/xfce-base/xfdesktop/ChangeLog
index 4d8b364e5962..bce96fa0ab16 100644
--- a/xfce-base/xfdesktop/ChangeLog
+++ b/xfce-base/xfdesktop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for xfce-base/xfdesktop
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.82 2007/02/09 16:42:37 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/ChangeLog,v 1.83 2007/02/15 01:36:53 nichoj Exp $
+
+ 15 Feb 2007; Joshua Nichols <nichoj@gentoo.org> xfdesktop-4.4.0-r3.ebuild:
+ Added linguas to IUSE for controlling installation of localized
+ configuration files.
*xfdesktop-4.4.0-r3 (09 Feb 2007)
diff --git a/xfce-base/xfdesktop/xfdesktop-4.4.0-r3.ebuild b/xfce-base/xfdesktop/xfdesktop-4.4.0-r3.ebuild
index 22e5d625416b..d692adf51d0a 100644
--- a/xfce-base/xfdesktop/xfdesktop-4.4.0-r3.ebuild
+++ b/xfce-base/xfdesktop/xfdesktop-4.4.0-r3.ebuild
@@ -1,15 +1,18 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.4.0-r3.ebuild,v 1.1 2007/02/09 16:42:37 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfdesktop/xfdesktop-4.4.0-r3.ebuild,v 1.2 2007/02/15 01:36:53 nichoj Exp $
inherit xfce44
xfce44
+xfce44_core_package
DESCRIPTION="Desktop manager"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="dbus debug doc minimal"
+LANG="ca cs da de el es et eu fi fr he hu ja ko nl pl pt_BR ro ru sk sv uk vi zh_CN zh_TW"
+
RDEPEND="x11-libs/libX11
x11-libs/libSM
>=dev-libs/glib-2.6
@@ -27,7 +30,14 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-util/intltool"
+for X in ${LANG}; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
XFCE_CONFIG="${XFCE_CONFIG} $(use_enable doc xsltproc)"
+DOCS="AUTHORS ChangeLog NEWS TODO README"
+XFCE_LOCALIZED_CONFIGS="/etc/xdg/xfce4/desktop/xfce-registered-categories.xml
+ /etc/xdg/xfce4/desktop/menu.xml"
pkg_setup() {
if use dbus; then
@@ -43,6 +53,17 @@ pkg_setup() {
fi
}
-DOCS="AUTHORS ChangeLog NEWS TODO README"
+src_install() {
+ xfce44_src_install
-xfce44_core_package
+ # clean out the config files that don't affect us
+ local config lang
+ for config in ${XFCE_LOCALIZED_CONFIGS}; do
+ for lang in ${LANG}; do
+ local localized_config="${D}/${config}.${lang}"
+ if [[ -f ${localized_config} ]]; then
+ use "linguas_${lang}" || rm ${localized_config}
+ fi
+ done
+ done
+}