summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-12-13 18:10:03 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-12-13 18:10:03 +0000
commit254acf2da326b985762821a12ff99446a6cab1a7 (patch)
tree168577e72aa568ed6078998d25391a57313a3225 /xfce-base
parentAdd ~x86 keyword. (diff)
downloadgentoo-2-254acf2da326b985762821a12ff99446a6cab1a7.tar.gz
gentoo-2-254acf2da326b985762821a12ff99446a6cab1a7.tar.bz2
gentoo-2-254acf2da326b985762821a12ff99446a6cab1a7.zip
Restore xfce4-panel-4.7.4 wrt #348615 by Sebastian Pipping (and Jory A. Pratt from IRC).
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-panel/ChangeLog7
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.7.4.ebuild42
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.7.6.ebuild4
3 files changed, 50 insertions, 3 deletions
diff --git a/xfce-base/xfce4-panel/ChangeLog b/xfce-base/xfce4-panel/ChangeLog
index 73bb00038c26..69ba2cc5c272 100644
--- a/xfce-base/xfce4-panel/ChangeLog
+++ b/xfce-base/xfce4-panel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-base/xfce4-panel
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.174 2010/12/05 16:05:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.175 2010/12/13 18:10:03 ssuominen Exp $
+
+ 13 Dec 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-panel-4.7.4.ebuild, xfce4-panel-4.7.6.ebuild:
+ Restore xfce4-panel-4.7.4 wrt #348615 by Sebastian Pipping (and Jory A. Pratt
+ from IRC).
*xfce4-panel-4.7.6 (05 Dec 2010)
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.7.4.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.7.4.ebuild
new file mode 100644
index 000000000000..7e2f763b28a4
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.7.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.7.4.ebuild,v 1.3 2010/12/13 18:10:03 ssuominen Exp $
+
+EAPI=3
+inherit xfconf
+
+DESCRIPTION="Xfce's panel"
+HOMEPAGE="http://www.xfce.org/projects/xfce4-panel/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND="x11-libs/libX11
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/garcon-0.1.4
+ >=xfce-base/libxfce4ui-4.7.1
+ >=xfce-base/xfconf-4.7.2
+ >=xfce-base/exo-0.5.1
+ >=x11-libs/gtk+-2.14:2
+ >=dev-libs/glib-2.18:2
+ >=dev-libs/dbus-glib-0.73
+ x11-libs/cairo
+ >=x11-libs/libwnck-2.22"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --disable-dependency-tracking
+ --disable-static
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+}
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.7.6.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.7.6.ebuild
index abc764d70a6a..7d59c84e4181 100644
--- a/xfce-base/xfce4-panel/xfce4-panel-4.7.6.ebuild
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.7.6.ebuild,v 1.1 2010/12/05 16:05:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.7.6.ebuild,v 1.2 2010/12/13 18:10:03 ssuominen Exp $
EAPI=3
inherit xfconf
@@ -11,7 +11,7 @@ SRC_URI="mirror://xfce/src/xfce/${PN}/4.7/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
IUSE="debug"
RDEPEND="x11-libs/libX11