summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2010-05-27 02:27:41 +0000
committerJeremy Olexa <darkside@gentoo.org>2010-05-27 02:27:41 +0000
commit3911930c30844ca45c5a5550a8b0ed4bbdd280b3 (patch)
treed6e7793d2289a31e2c4d062ce27f18e7596b4886 /xfce-extra/thunar-archive-plugin
parentRemove old version; fix testing (bug #321617); add support for Ruby 1.9, JRub... (diff)
downloadgentoo-2-3911930c30844ca45c5a5550a8b0ed4bbdd280b3.tar.gz
gentoo-2-3911930c30844ca45c5a5550a8b0ed4bbdd280b3.tar.bz2
gentoo-2-3911930c30844ca45c5a5550a8b0ed4bbdd280b3.zip
Revision bump to add patch that supports 7z/lzma/xz formats, bug 313783
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/thunar-archive-plugin')
-rw-r--r--xfce-extra/thunar-archive-plugin/ChangeLog9
-rw-r--r--xfce-extra/thunar-archive-plugin/files/thunar-archive-plugin-0.2.4-7zlzmaxz.patch26
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.2.4-r2.ebuild32
3 files changed, 66 insertions, 1 deletions
diff --git a/xfce-extra/thunar-archive-plugin/ChangeLog b/xfce-extra/thunar-archive-plugin/ChangeLog
index ebf67529199d..219f3512a347 100644
--- a/xfce-extra/thunar-archive-plugin/ChangeLog
+++ b/xfce-extra/thunar-archive-plugin/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/thunar-archive-plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/ChangeLog,v 1.3 2010/01/15 02:37:55 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/ChangeLog,v 1.4 2010/05/27 02:27:41 darkside Exp $
+
+*thunar-archive-plugin-0.2.4-r2 (27 May 2010)
+
+ 27 May 2010; Jeremy Olexa <darkside@gentoo.org>
+ +thunar-archive-plugin-0.2.4-r2.ebuild,
+ +files/thunar-archive-plugin-0.2.4-7zlzmaxz.patch:
+ Revision bump to add patch that supports 7z/lzma/xz formats, bug 313783
15 Jan 2010; Samuli Suominen <ssuominen@gentoo.org>
thunar-archive-plugin-0.2.4-r1.ebuild:
diff --git a/xfce-extra/thunar-archive-plugin/files/thunar-archive-plugin-0.2.4-7zlzmaxz.patch b/xfce-extra/thunar-archive-plugin/files/thunar-archive-plugin-0.2.4-7zlzmaxz.patch
new file mode 100644
index 000000000000..2e3c65e1a329
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/files/thunar-archive-plugin-0.2.4-7zlzmaxz.patch
@@ -0,0 +1,26 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=6136
+--- thunar-archive-plugin-0.2.4-old/thunar-archive-plugin/tap-provider.c 2007-01-20 12:41:50.000000000 +0200
++++ thunar-archive-plugin-0.2.4/thunar-archive-plugin/tap-provider.c 2010-01-10 01:05:12.857875928 +0200
+@@ -97,6 +97,8 @@
+
+
+ static const gchar TAP_MIME_TYPES[][34] = {
++ "application/x-7z-compressed",
++ "application/x-7z-compressed-tar",
+ "application/x-ar",
+ "application/x-arj",
+ "application/x-bzip",
+@@ -108,9 +110,13 @@
+ "application/x-gzip",
+ "application/x-lha",
+ "application/x-lhz",
++ "application/x-lzma",
++ "application/x-lzma-compressed-tar",
+ "application/x-rar",
+ "application/x-rar-compressed",
+ "application/x-tar",
++ "application/x-xz",
++ "application/x-xz-compressed-tar",
+ "application/x-zip",
+ "application/x-zip-compressed",
+ "application/zip",
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.2.4-r2.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.2.4-r2.ebuild
new file mode 100644
index 000000000000..fbaa5663fac2
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.2.4-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.2.4-r2.ebuild,v 1.1 2010/05/27 02:27:41 darkside Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Thunar archive plugin"
+HOMEPAGE="http://www.foo-projects.org/~benny/projects/thunar-archive-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/0.2/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+COMMON_DEPEND="<xfce-base/thunar-1.1.0"
+RDEPEND="${COMMON_DEPEND}
+ || ( app-arch/xarchiver
+ kde-base/ark
+ app-arch/file-roller
+ app-arch/squeeze )"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(xfconf_use_debug)"
+ DOCS="AUTHORS ChangeLog NEWS README THANKS"
+ PATCHES=( "${FILESDIR}/${P}-7zlzmaxz.patch" )
+}