summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/uwsgi/ChangeLog6
-rw-r--r--www-servers/uwsgi/files/42_mod_uwsgi.conf2
-rw-r--r--www-servers/uwsgi/uwsgi-0.9.6.6.ebuild15
3 files changed, 20 insertions, 3 deletions
diff --git a/www-servers/uwsgi/ChangeLog b/www-servers/uwsgi/ChangeLog
index 26de4c5cb821..023b2877c6b4 100644
--- a/www-servers/uwsgi/ChangeLog
+++ b/www-servers/uwsgi/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/uwsgi
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/ChangeLog,v 1.2 2011/01/07 14:22:20 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/ChangeLog,v 1.3 2011/01/10 10:54:39 dev-zero Exp $
+
+ 10 Jan 2011; Tiziano Müller <dev-zero@gentoo.org> files/42_mod_uwsgi.conf,
+ uwsgi-0.9.6.6.ebuild:
+ mod_Ruwsgi and mod_uwsgi are mutually exclusive.
*uwsgi-0.9.6.6 (07 Jan 2011)
diff --git a/www-servers/uwsgi/files/42_mod_uwsgi.conf b/www-servers/uwsgi/files/42_mod_uwsgi.conf
index 236bf564cdd4..a619baeafeeb 100644
--- a/www-servers/uwsgi/files/42_mod_uwsgi.conf
+++ b/www-servers/uwsgi/files/42_mod_uwsgi.conf
@@ -2,6 +2,6 @@
LoadModule uwsgi_module modules/mod_uwsgi.so
</IfDefine>
<IfDefine RUWSGI>
- LoadModule Ruwsgi_module modules/mod_Ruwsgi.so
+ LoadModule uwsgi_module modules/mod_Ruwsgi.so
</IfDefine>
diff --git a/www-servers/uwsgi/uwsgi-0.9.6.6.ebuild b/www-servers/uwsgi/uwsgi-0.9.6.6.ebuild
index 8887b03a4899..fc3da5e8165a 100644
--- a/www-servers/uwsgi/uwsgi-0.9.6.6.ebuild
+++ b/www-servers/uwsgi/uwsgi-0.9.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/uwsgi-0.9.6.6.ebuild,v 1.1 2011/01/07 14:22:20 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/uwsgi-0.9.6.6.ebuild,v 1.2 2011/01/10 10:54:39 dev-zero Exp $
EAPI="3"
PYTHON_DEPEND="*"
@@ -55,3 +55,16 @@ src_install() {
done
fi
}
+
+pkg_postinst() {
+ python_pkg_postinst
+
+ if use apache2 ; then
+ elog "Two Apache modules have been installed: mod_uwsgi and mod_Ruwsgi."
+ elog "You can enable them with -DUWSGI or -DRUWSGI in /etc/conf.d/apache2."
+ elog "Both have the same configuration interface and define the same symbols."
+ elog "Therefore you can enable only one of them at a time."
+ elog "mod_uwsgi is commercially supported by Unbit and stable but a bit hacky."
+ elog "mod_Ruwsgi is newer and more Apache-API friendly but not commercially supported."
+ fi
+}