summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/loudmouth/ChangeLog6
-rw-r--r--net-libs/loudmouth/files/loudmouth-0.15-gnutls_1.0.patch10
-rw-r--r--net-libs/loudmouth/loudmouth-0.15.ebuild7
3 files changed, 21 insertions, 2 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index 5d729f5de1f6..a5c9b3db8fc2 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/loudmouth
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.12 2004/01/22 18:23:15 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.13 2004/02/06 02:01:34 liquidx Exp $
+
+ 06 Feb 2004; Alastair Tse <liquidx@gentoo.org> loudmouth-0.15.ebuild,
+ files/loudmouth-0.15-gnutls_1.0.patch:
+ add workaround for gnutls-1.0 incompatibility
*loudmouth-0.15 (22 Jan 2004)
diff --git a/net-libs/loudmouth/files/loudmouth-0.15-gnutls_1.0.patch b/net-libs/loudmouth/files/loudmouth-0.15-gnutls_1.0.patch
new file mode 100644
index 000000000000..3d8c121afa26
--- /dev/null
+++ b/net-libs/loudmouth/files/loudmouth-0.15-gnutls_1.0.patch
@@ -0,0 +1,10 @@
+--- loudmouth/lm-ssl.c.old 2004-02-06 01:50:08.231324136 +0000
++++ loudmouth/lm-ssl.c 2004-02-06 01:50:17.034985776 +0000
+@@ -72,7 +72,6 @@
+
+ if (status & GNUTLS_CERT_INVALID
+ || status & GNUTLS_CERT_NOT_TRUSTED
+- || status & GNUTLS_CERT_CORRUPTED
+ || status & GNUTLS_CERT_REVOKED) {
+ if (ssl->func (ssl, LM_SSL_STATUS_UNTRUSTED_CERT,
+ ssl->func_data) != LM_SSL_RESPONSE_CONTINUE) {
diff --git a/net-libs/loudmouth/loudmouth-0.15.ebuild b/net-libs/loudmouth/loudmouth-0.15.ebuild
index 6fcb6fa66cf7..122ee397d5dc 100644
--- a/net-libs/loudmouth/loudmouth-0.15.ebuild
+++ b/net-libs/loudmouth/loudmouth-0.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-0.15.ebuild,v 1.1 2004/01/22 18:23:15 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-0.15.ebuild,v 1.2 2004/02/06 02:01:34 liquidx Exp $
inherit gnome2
@@ -25,3 +25,8 @@ DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
use ssl \
&& G2CONF="${G2CONF} --with-ssl" \
|| G2CONF="${G2CONF} --without-ssl"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}; epatch ${FILESDIR}/${P}-gnutls_1.0.patch
+}