summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/Manifest10
-rw-r--r--net-analyzer/cacti/cacti-0.8.6b.ebuild5
-rw-r--r--net-analyzer/cacti/cacti-0.8.6c.ebuild5
-rw-r--r--net-analyzer/cacti/cacti-0.8.6d.ebuild5
-rw-r--r--net-analyzer/cacti/files/postinstall-en.txt11
6 files changed, 22 insertions, 22 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 548927093e44..b50527870b18 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.42 2005/04/29 17:44:39 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.43 2005/05/02 11:23:48 eldad Exp $
+
+ 02 May 2005; Eldad Zack <eldad@gentoo.org> files/postinstall-en.txt,
+ cacti-0.8.6b.ebuild, cacti-0.8.6c.ebuild, cacti-0.8.6d.ebuild:
+ Fixed to use the webapp_configfile function for include/config.php. Updated
+ postinstall accordingly. Closes bug #90908. Thanks to Andy Blyler
+ <ajb@blyler.cc>.
*cacti-0.8.6d (29 Apr 2005)
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 5580554ff87f..32fdbd2313aa 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,9 +1,9 @@
MD5 f336eb6ba3c459b9b17078d8a317871a cacti-0.8.6c.ebuild 1358
-MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
-MD5 3a8038fcb39908f7f983485ad8d27b66 ChangeLog 5706
-MD5 7add9f072dcf20a50fa7b3d3b31db461 cacti-0.8.6d.ebuild 1358
MD5 2c655694731b7e285fed83e0f3a7d069 cacti-0.8.6b.ebuild 1358
-MD5 92214d64b7a546022d81ca37cb137262 files/digest-cacti-0.8.6c 65
-MD5 e77a5f6b9f7c97f061348312cd9e1004 files/digest-cacti-0.8.6d 65
+MD5 3a8038fcb39908f7f983485ad8d27b66 ChangeLog 5706
+MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
+MD5 5718e1f7267216bd3f3d0da4c1f56a64 cacti-0.8.6d.ebuild 1334
MD5 33517a617de6d446ec51405f3eb2757c files/postinstall-en.txt 2233
MD5 5415dc0df13fd1528eb90acce7f44989 files/digest-cacti-0.8.6b 65
+MD5 92214d64b7a546022d81ca37cb137262 files/digest-cacti-0.8.6c 65
+MD5 e77a5f6b9f7c97f061348312cd9e1004 files/digest-cacti-0.8.6d 65
diff --git a/net-analyzer/cacti/cacti-0.8.6b.ebuild b/net-analyzer/cacti/cacti-0.8.6b.ebuild
index 9c991577a408..394a3e79004d 100644
--- a/net-analyzer/cacti/cacti-0.8.6b.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6b.ebuild,v 1.7 2005/03/09 12:23:35 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6b.ebuild,v 1.8 2005/05/02 11:23:48 eldad Exp $
inherit eutils webapp
@@ -44,14 +44,13 @@ src_install() {
dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
rm -rf docs
- #Don't overwrite old config
- mv include/config.php include/config-sample.php
edos2unix `find -type f -name '*.php'`
dodir ${MY_HTDOCSDIR}
cp -r . ${D}${MY_HTDOCSDIR}
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
webapp_src_install
diff --git a/net-analyzer/cacti/cacti-0.8.6c.ebuild b/net-analyzer/cacti/cacti-0.8.6c.ebuild
index 1b6a7a06d61d..51efbd48e61c 100644
--- a/net-analyzer/cacti/cacti-0.8.6c.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6c.ebuild,v 1.5 2005/03/09 12:23:35 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6c.ebuild,v 1.6 2005/05/02 11:23:48 eldad Exp $
inherit eutils webapp
@@ -44,14 +44,13 @@ src_install() {
dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
rm -rf docs
- #Don't overwrite old config
- mv include/config.php include/config-sample.php
edos2unix `find -type f -name '*.php'`
dodir ${MY_HTDOCSDIR}
cp -r . ${D}${MY_HTDOCSDIR}
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
webapp_src_install
diff --git a/net-analyzer/cacti/cacti-0.8.6d.ebuild b/net-analyzer/cacti/cacti-0.8.6d.ebuild
index 53a981b7862e..1432a34e58c7 100644
--- a/net-analyzer/cacti/cacti-0.8.6d.ebuild
+++ b/net-analyzer/cacti/cacti-0.8.6d.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6d.ebuild,v 1.1 2005/04/29 17:44:39 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.6d.ebuild,v 1.2 2005/05/02 11:23:48 eldad Exp $
inherit eutils webapp
@@ -44,14 +44,13 @@ src_install() {
dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
rm -rf docs
- #Don't overwrite old config
- mv include/config.php include/config-sample.php
edos2unix `find -type f -name '*.php'`
dodir ${MY_HTDOCSDIR}
cp -r . ${D}${MY_HTDOCSDIR}
+ webapp_configfile ${MY_HTDOCSDIR}/include/config.php
webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
webapp_src_install
diff --git a/net-analyzer/cacti/files/postinstall-en.txt b/net-analyzer/cacti/files/postinstall-en.txt
index 0a59c13bf169..ec5b7b7f4dd2 100644
--- a/net-analyzer/cacti/files/postinstall-en.txt
+++ b/net-analyzer/cacti/files/postinstall-en.txt
@@ -9,8 +9,8 @@ New Install
shell> mysql -p --user=root mysql
mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';
mysql> flush privileges;
-4. Copy ${MY_INSTALLDIR}/include/config-sample.php to config.php
- And modify the MySQL user, password and database for your cacti configuration.
+4. Edit ${MY_INSTALLDIR}/include/config.php and modify the MySQL user,
+ password and database for your cacti configuration.
Example:
\$database_default = "cacti";
@@ -28,10 +28,7 @@ Upgrading
shell> mysqldump -l --add-drop-table cacti > mysql.cacti
2. Backup your rra/ directory and any custom scripts in your scripts/
directory.
-3. Copy ${MY_INSTALLDIR}/include/config-sample.php to config.php
- And modify the MySQL user, password and database for your cacti
- configuration.
-4. Edit ${MY_INSTALLDIR}/include/config.php, and confirm that the MySQL user,
+3. Edit ${MY_INSTALLDIR}/include/config.php, and confirm that the MySQL user,
password and database is correct for your cacti configuration.
Example:
@@ -39,7 +36,7 @@ Upgrading
\$database_hostname = "localhost";
\$database_username = "cactiuser";
\$database_password = "cacti";
-5. Point your web browser to: http://your-server/cacti/
+4. Point your web browser to: http://your-server/cacti/
Select "Upgrade:.
Make sure to fill in all of the path variables carefully and
correctly on the following screen.