summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kontact/ChangeLog7
-rw-r--r--kde-base/kontact/kontact-4.2.4.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kontact/ChangeLog b/kde-base/kontact/ChangeLog
index f1a4df2c0c7a..be3582c490c6 100644
--- a/kde-base/kontact/ChangeLog
+++ b/kde-base/kontact/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kontact
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.117 2009/06/03 19:52:19 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/ChangeLog,v 1.118 2009/06/04 13:04:14 alexxy Exp $
+
+*kontact-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> +kontact-4.2.4.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -kontact-4.2.2.ebuild:
Drop KDE 4.2.2
diff --git a/kde-base/kontact/kontact-4.2.4.ebuild b/kde-base/kontact/kontact-4.2.4.ebuild
new file mode 100644
index 000000000000..71b87cf116d5
--- /dev/null
+++ b/kde-base/kontact/kontact-4.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/kontact-4.2.4.ebuild,v 1.1 2009/06/04 13:04:14 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +handbook"
+
+DEPEND="
+ app-crypt/gpgme
+ >=kde-base/kontactinterfaces-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkdepim-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+"
+
+KMLOADLIBS="libkdepim"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+#
+# xml targets from kmail/ are being uncommented by kde4-meta.eclass
+KMEXTRACTONLY="
+ kmail/
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/kmobiletools
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ kontactinterfaces/
+"