summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-base/kfind/ChangeLog5
-rw-r--r--kde-base/kfind/kfind-4.2.1.ebuild15
2 files changed, 15 insertions, 5 deletions
diff --git a/kde-base/kfind/ChangeLog b/kde-base/kfind/ChangeLog
index e7485f7f5829..1012086f389c 100644
--- a/kde-base/kfind/ChangeLog
+++ b/kde-base/kfind/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for kde-base/kfind
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kfind/ChangeLog,v 1.111 2009/03/09 11:48:14 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kfind/ChangeLog,v 1.112 2009/03/13 17:47:49 scarabeus Exp $
+
+ 13 Mar 2009; Tomas Chvatal <scarabeus@gentoo.org> kfind-4.2.1.ebuild:
+ Update kmextra.
09 Mar 2009; Tomas Chvatal <scarabeus@gentoo.org> kfind-4.2.1.ebuild:
Fix wrong kmextra.
diff --git a/kde-base/kfind/kfind-4.2.1.ebuild b/kde-base/kfind/kfind-4.2.1.ebuild
index 8052fb8e2301..b14e2e9ff92b 100644
--- a/kde-base/kfind/kfind-4.2.1.ebuild
+++ b/kde-base/kfind/kfind-4.2.1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kfind/kfind-4.2.1.ebuild,v 1.4 2009/03/09 11:48:14 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kfind/kfind-4.2.1.ebuild,v 1.5 2009/03/13 17:47:49 scarabeus Exp $
EAPI="2"
-KMNAME="kdebase"
-KMMODULE="apps/${PN}"
+KMNAME="kdebase-apps"
inherit kde4-meta
DESCRIPTION="KDE file finder utility"
@@ -12,5 +11,13 @@ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="debug"
KMEXTRA="
- apps/doc/${PN}/
+ doc/${PN}/
"
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ # Note that this is already fixed for 4.2.2
+ sed -i -e 's/ konq / /' \
+ kfind/CMakeLists.txt || die "failed to disable libkonq from link"
+}