summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/prawn-core/ChangeLog8
-rw-r--r--dev-ruby/prawn-core/prawn-core-0.7.2.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/prawn-core/ChangeLog b/dev-ruby/prawn-core/ChangeLog
index b5b3e5ca4843..1f485aac0491 100644
--- a/dev-ruby/prawn-core/ChangeLog
+++ b/dev-ruby/prawn-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/prawn-core
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-core/ChangeLog,v 1.2 2010/01/28 19:11:39 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-core/ChangeLog,v 1.3 2010/02/01 09:22:32 flameeyes Exp $
+
+*prawn-core-0.7.2 (01 Feb 2010)
+
+ 01 Feb 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +prawn-core-0.7.2.ebuild:
+ Version bump.
28 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
prawn-core-0.7.1.ebuild:
diff --git a/dev-ruby/prawn-core/prawn-core-0.7.2.ebuild b/dev-ruby/prawn-core/prawn-core-0.7.2.ebuild
new file mode 100644
index 000000000000..88915083a287
--- /dev/null
+++ b/dev-ruby/prawn-core/prawn-core-0.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/prawn-core/prawn-core-0.7.2.ebuild,v 1.1 2010/02/01 09:22:32 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="HACKING README"
+
+# ttfunk and pdf-inspector are vendored, and the versions currently
+# there are not identical to the versions we already carry in our
+# tree. To be fixed.
+RUBY_FAKEGEM_EXTRAINSTALL="data vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Fast, Nimble PDF Generation For Ruby"
+HOMEPAGE="http://prawn.majesticseacreature.com/"
+
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+ruby_add_bdepend test "dev-ruby/test-spec dev-ruby/mocha dev-ruby/pdf-reader"
+
+# Older versions of prawn install the same files, but in site_ruby
+# which gets found before the newer gem install path that prawn-core
+# uses.
+RDEPEND="!<dev-ruby/prawn-0.7"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples || die "Installing examples failed."
+ fi
+}