summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-firewall/ipt_netflow/ChangeLog8
-rw-r--r--net-firewall/ipt_netflow/files/ipt_netflow-2.0-pax-const.patch4
-rw-r--r--net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild84
3 files changed, 93 insertions, 3 deletions
diff --git a/net-firewall/ipt_netflow/ChangeLog b/net-firewall/ipt_netflow/ChangeLog
index 03b9008cc699..937b947bb3f7 100644
--- a/net-firewall/ipt_netflow/ChangeLog
+++ b/net-firewall/ipt_netflow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-firewall/ipt_netflow
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.16 2014/08/19 07:21:25 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ChangeLog,v 1.17 2014/09/16 06:06:52 jer Exp $
+
+*ipt_netflow-2.0.1 (16 Sep 2014)
+
+ 16 Sep 2014; Jeroen Roovers <jer@gentoo.org> +ipt_netflow-2.0.1.ebuild,
+ files/ipt_netflow-2.0-pax-const.patch:
+ Version bump.
*ipt_netflow-2.0-r1 (19 Aug 2014)
diff --git a/net-firewall/ipt_netflow/files/ipt_netflow-2.0-pax-const.patch b/net-firewall/ipt_netflow/files/ipt_netflow-2.0-pax-const.patch
index 8a1270109652..fdf369314427 100644
--- a/net-firewall/ipt_netflow/files/ipt_netflow-2.0-pax-const.patch
+++ b/net-firewall/ipt_netflow/files/ipt_netflow-2.0-pax-const.patch
@@ -4,8 +4,8 @@ Adds support for building with PaX hardened kernel
Adapted to version 2.0 by Sergey Popov <pinkbyte@gentoo.org>
---- ipt_NETFLOW.c.orig 2014-08-07 08:05:08.000000000 +0400
-+++ ipt_NETFLOW.c 2014-08-18 11:10:08.000000000 +0400
+--- a/ipt_NETFLOW.c
++++ b/ipt_NETFLOW.c
@@ -845,13 +845,13 @@
void __user *buffer, size_t *lenp, loff_t *fpos)
{
diff --git a/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild b/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild
new file mode 100644
index 000000000000..dd61633afaec
--- /dev/null
+++ b/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipt_netflow/ipt_netflow-2.0.1.ebuild,v 1.1 2014/09/16 06:06:52 jer Exp $
+
+EAPI=5
+inherit eutils linux-info linux-mod multilib toolchain-funcs
+
+DESCRIPTION="Netflow iptables module"
+HOMEPAGE="http://sourceforge.net/projects/ipt-netflow"
+SRC_URI="mirror://sourceforge/ipt-netflow/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug pax_kernel"
+
+RDEPEND="net-firewall/iptables"
+DEPEND="${RDEPEND}
+ virtual/linux-sources
+ virtual/pkgconfig
+"
+
+# set S before MODULE_NAMES
+S="${WORKDIR}/${PN/_/-}-${PV}"
+
+BUILD_TARGETS="all"
+MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
+
+IPT_LIB="/usr/$(get_libdir)/xtables"
+
+pkg_setup() {
+ local CONFIG_CHECK="~IP_NF_IPTABLES"
+ use debug && CONFIG_CHECK+=" ~DEBUG_FS"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:make -C:$(MAKE) -C:g' \
+ -e 's:gcc -O2:$(CC) $(CFLAGS) $(LDFLAGS):' \
+ -e 's:gcc:$(CC) $(CFLAGS) $(LDFLAGS):' \
+ Makefile.in || die
+
+ # bug #455984
+ epatch "${FILESDIR}/${PN}-2.0-configure.patch"
+
+ # bugs #466430 and #519480
+ if use pax_kernel; then
+ epatch "${FILESDIR}/${PN}-2.0-pax-const.patch"
+ fi
+
+ epatch_user
+}
+
+do_conf() {
+ echo ./configure $*
+ ./configure $* || die 'configure failed'
+}
+
+src_configure() {
+ local IPT_VERSION="$($(tc-getPKG_CONFIG) --modversion xtables)"
+ # this configure script is not based on autotools
+ # ipt-src need to be defined, see bug #455984
+ do_conf \
+ --ipt-lib="${IPT_LIB}" \
+ --ipt-src="/usr/" \
+ --ipt-ver="${IPT_VERSION}" \
+ --kdir="${KV_DIR}" \
+ --kver="${KV_FULL}" \
+ $(use debug && echo '--enable-debugfs')
+}
+
+src_compile() {
+ emake ARCH="$(tc-arch-kernel)" CC="$(tc-getCC)" all
+}
+
+src_install() {
+ linux-mod_src_install
+ exeinto "${IPT_LIB}"
+ doexe libipt_NETFLOW.so
+ doheader ipt_NETFLOW.h
+ dodoc README*
+}