summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-misc/curl/curl-7.10.8-r1.ebuild4
-rw-r--r--net-misc/curl/curl-7.11.0.ebuild4
-rw-r--r--net-misc/curl/curl-7.11.1.ebuild4
-rw-r--r--net-misc/curl/curl-7.12.0-r2.ebuild6
-rw-r--r--net-misc/curl/curl-7.12.3.ebuild47
-rw-r--r--net-misc/curl/files/digest-curl-7.12.31
6 files changed, 58 insertions, 8 deletions
diff --git a/net-misc/curl/curl-7.10.8-r1.ebuild b/net-misc/curl/curl-7.10.8-r1.ebuild
index 1da3f73e8158..e3dc78db7e46 100644
--- a/net-misc/curl/curl-7.10.8-r1.ebuild
+++ b/net-misc/curl/curl-7.10.8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.10.8-r1.ebuild,v 1.3 2004/06/24 23:40:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.10.8-r1.ebuild,v 1.4 2005/01/13 16:52:53 liquidx Exp $
inherit eutils
diff --git a/net-misc/curl/curl-7.11.0.ebuild b/net-misc/curl/curl-7.11.0.ebuild
index f8e9ecafe67f..cbb955084d1e 100644
--- a/net-misc/curl/curl-7.11.0.ebuild
+++ b/net-misc/curl/curl-7.11.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.11.0.ebuild,v 1.6 2004/10/04 22:16:35 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.11.0.ebuild,v 1.7 2005/01/13 16:52:53 liquidx Exp $
DESCRIPTION="A Client that groks URLs"
SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
diff --git a/net-misc/curl/curl-7.11.1.ebuild b/net-misc/curl/curl-7.11.1.ebuild
index 956248b9d08c..ee6b8f2b30a2 100644
--- a/net-misc/curl/curl-7.11.1.ebuild
+++ b/net-misc/curl/curl-7.11.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.11.1.ebuild,v 1.6 2004/10/19 12:31:59 absinthe Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.11.1.ebuild,v 1.7 2005/01/13 16:52:53 liquidx Exp $
DESCRIPTION="A Client that groks URLs"
HOMEPAGE="http://curl.haxx.se/"
diff --git a/net-misc/curl/curl-7.12.0-r2.ebuild b/net-misc/curl/curl-7.12.0-r2.ebuild
index b1f3638769f1..f49bf094cfc2 100644
--- a/net-misc/curl/curl-7.12.0-r2.ebuild
+++ b/net-misc/curl/curl-7.12.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.12.0-r2.ebuild,v 1.8 2005/01/12 13:25:49 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.12.0-r2.ebuild,v 1.9 2005/01/13 16:52:53 liquidx Exp $
# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
@@ -18,6 +18,8 @@ IUSE="ssl ipv6 ldap"
DEPEND="ssl? ( >=dev-libs/openssl-0.9.6a )
ldap? ( net-nds/openldap )"
+RESTRICT="maketest"
+
src_unpack() {
unpack ${A}
cd ${S}
diff --git a/net-misc/curl/curl-7.12.3.ebuild b/net-misc/curl/curl-7.12.3.ebuild
new file mode 100644
index 000000000000..ddfe31050d6b
--- /dev/null
+++ b/net-misc/curl/curl-7.12.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/curl/curl-7.12.3.ebuild,v 1.1 2005/01/13 16:52:53 liquidx Exp $
+
+# NOTE: If you bump this ebuild, make sure you bump dev-python/pycurl!
+
+inherit eutils
+
+DESCRIPTION="A Client that groks URLs"
+HOMEPAGE="http://curl.haxx.se/"
+SRC_URI="http://curl.haxx.se/download/${P}.tar.bz2"
+
+LICENSE="MIT X11"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ppc64 ~s390"
+IUSE="ssl ipv6 ldap"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6a )
+ ldap? ( net-nds/openldap )"
+
+RESTRICT="maketest"
+
+src_compile() {
+ econf \
+ `use_enable ipv6` \
+ `use_enable ldap` \
+ `use_with ssl` \
+ --enable-http \
+ --enable-ftp \
+ --enable-gopher \
+ --enable-file \
+ --enable-dict \
+ --enable-manual \
+ --enable-telnet \
+ --enable-nonblocking \
+ --enable-largefile \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc LEGAL CHANGES README
+ dodoc docs/FEATURES docs/INSTALL docs/INTERNALS docs/LIBCURL
+ dodoc docs/MANUAL docs/FAQ docs/BUGS docs/CONTRIBUTE
+
+}
diff --git a/net-misc/curl/files/digest-curl-7.12.3 b/net-misc/curl/files/digest-curl-7.12.3
new file mode 100644
index 000000000000..62500360f3c0
--- /dev/null
+++ b/net-misc/curl/files/digest-curl-7.12.3
@@ -0,0 +1 @@
+MD5 a71b80538872245b984e176de932e99e curl-7.12.3.tar.bz2 1830712